I don't know how WD My Passport works

To start things right off the bat, I know jack squat about how computers. Hard drives, storage, coding, absolutely nothing. Heck, the PC that I’m using (which was built 5 years ago) was built by my brother when I was in middle school. Anyways, while I don’t know anything about computers and hard drive, I do know that my computer is low on storage. So yesterday, I bought the WD My Passport external hard drive and oh boy, is it harder to use than I thought. You’d think after plugging in the thing and installing it on the computer that moving files to it would be as easy as 1 2 3, right? Well, in my case, no. I’ve tried transferred some photos to the passport but the the internal hard drive bar (when you click on my computer in files) is still in the red while the passport bar is completely empty. So I think "oh maybe it’s because I haven’t downloaded the apps when you click on wd discover in the hidden icon bar. Tried downloading WD backups and installation failed every time. So I think “well maybe it’s because I haven’t created a My Cloud account”. So I created an account, typed in the username and password on WD Discover, pressed sign in and began loading. After hours of waiting and a day later, it’s still loading!

So I have no idea what I’m doing. I don’t know why the Passport isn’t working. I dont know weather it’s due to me not being signed in! And I don’t even know why it buffers when I press sign in!

I hope I can get some answers here, cause I really don’t know what to do

Yes … and it is as easy as 1 2 3, for most people

The capacity bar on your PC’s hard drive turns Red when you have less than 10% free … so, let’s assume you are using a 1TB hard drive in your PC … you would have to transfer well over 100GB of ‘Photos’ or files for the capacity color to change. (photo’s take up very little space and a 100GB of them would be Millions of photos)

If you copied files to the WD My Passport they should be there … ignore the “passport bar” (as you call it) … double click on the “My Passport” Hard drive Icon, you should see the files you copied.

If you don’t … then you did something wrong, try again … and for everything else you tried in post, that has nothing to do with copying files.