I changed my router and now I can't even see my Network Shares - using Win 7 - help


#1

It’s quite incredible, but I am so lost here…  spent 6 hours with WD and Linksys tech support online… and still no answers.

Running Windows 7 Ultimate (64-bit) with WD TV Live, which has the Linksys WUSB600 dual-band wireless-N USB adapter plugged in.  My PC has no user accounts /  passwords so there are ni profiles.

I followed the setup /  installation instructions from this link:

http://community.wdc.com/t5/Networking/Enable-Network-Shares-on-WD-TV-Live-amp-Windows-7-amp-Vista-32/m-p/6842#M557

Worked like a charm - for 4 days.

Earlier today, I decided to “upgrade” my old Linksys WRT300N router to the WRT610N new one, so that I can have better streaming with the dual-band.     Here is the bottom line:  When I now go to “shared networks”, I only see the router itself listed.    There are no more network shares foldere/directories that were working perfectly with WRT300N.   So I decided to “go back” to the WRT300N, and guess what, the network shares dissapeared there also.  The WRT300N router is not shown.

I have tried (and not limited to the following):

Factory reset my WD HD Live and re-setup from scratch

re-created the network share folders on the PC

re-set advanced sharing settings / media streaming / sharing parameters, etc…

Uninstalled / re-installed the ETHERNET drivers on my PC

REPLACED the WRT610N router with another one (swaped at the store I bought yesterday)

Disabled Windows 7 firewall/ Kaspersky 2010 antivirus and buit-in firewall of WRT610N

tried Auto login to network share > On / Off, cleared cache…

and many other things and still no go

I do know that the WRT610N is seen by WD HD Live because I am able to stream Youtube videos without a problem and I am able to ping 192.168.0.103 (WD HD Live) from my PC.   Also, . the WDTV Live icon is displayed under Network / Media Devices.   My Linksys WRT610N is displayed under Network / Network Infrastructure.  

I am at a loss of words… why would it work fine for 4 days, then when I try to change the router… it breaks everything.

Any ideas?!?!?


#2

One thing I’d try would be switching to password protected shares. It may seem to add a layer of complexity rather than make it simpler, but it could make it work better.

It’s as simple as turning on network protected shares in “advanced network settings”, and then creating a new account just for the WDTV live. I’ve created a second account (standard user) named WDTVLIVE, with a simple password (just lowercase letters), because with my normal account it wouldn’t accept my password (has both upper&lowercase letters plus a space). It works like a charm, and the WDTV live can easily logon to that account while the box is logged on my normal account. It works both in Windows 7 32 bit and 64 bit versions, but ofc your mileage may vary.

Other things you might try is changing IP assignations, such as assigning static IPs to your WDTV live and especially your PC’s, activate uPnP on your router, or change your local workgroup to “WORKGROUP”.

If nothing works for you, you can always “forget” about the network shares and try with media servers, they work more than well in my own experience. For listening to music (flac) or watching videos up to 720p I usually do it from the network shares, but whenever I watch a movie in 1080p I always do it with TVersity nowadays. For some reason the WDTV live doesn’t seem to be able to pull content at more than 20 Mbit/s or so when you play from network shares, and that can cause problems with some 080p videos that have peaks over 20-25 Mbit/s, causing stuttering. However TVersity and other media servers don’t have any problems in streaming videos with peaks well over 35 Mbit/s.

PS: oh I almost forgot…  in case you didn’t try yet, try connecting either or both the WDTV live and the PC sharing the media to the router with a wired connection.


#3

I appreciate the input and the ideas.  I already have the UPNP activated on the router.   I would rather not use a paid service some as TVersity for something that is supposed to do it for “free”.

However, nothing can explain the fact that it was working with WRT300N, then not with WRT610N and then when I went back to plug-in the WRT300N, it wont work with it either.  

I am just stuck.


#4

Actually TVersity is free, the licensed version is only there if you wanna stream certain internet content like Hulu etc… For streaming local content the free version is fully functional, and ad-free. Ofc it would be nice to find a solution for the network shares, but in the meantime it’s nice to have an alternative, and one that works well and easily too.

Also as I wrote above, even if you get the network shares to work you might get occasional problems with some 1080p videos if they’re encoded with high bitrates, the media servers however don’t have those problems.


#5

You might might find there are replicated WDTVLIVE entries under the Network Sharing box in your Win 7, and each entry has a different IP address associated with it. This was the case for my Win 7 (32-bit) when I replaced routers (each router may assign a different IP address to the WDTV) which is in turn resgistered to Win 7, and the duplication caused havoc for Win 7.  After checking the IP address on the WDTV, I deleted the inapproriate entry  in WIn 7.

Just something to toy with.


#6

Interesting idea.  Where and how does one DELETE this entry in Windows 7?


#7

Try:  Control Panel -> Network and Internet -> HomeGroup -> Choose media streaming option


#8

I have no Homegroups…


#9

Out of desperation, I once again tried to reconnect the WRT300N router back on the system, and guess what? 

Everything is working like a charm again.    I did not have to touch any settings on Windows 7 …

So this tells me that WD TV Live has incompatibility with the Linksys WRT610N v2 router and therefore, I am returning it back to the store. 

  

Funny enough, I watched 45 minutes of 1080i video yesterday without any “skipping” from my WRT300N, on a mixed signal using 20Mhz.