I can't setup the SMB and the default is too slow on mac

I’m using a macbook pro and I set up the My Cloud Home with my 10/100/1000 Modem Router
The default driver set by the My Cloud Home is to slow.

So I saw some comments and videos on how to set the SMB:// protocol but I keep getting this error after entering the username and pass

There was a problem connecting to the server “192.168.0.xxx”.
Check the server name or IP address, and then try again. If you continue to have problems, contact your system administrator.

I’m 100% sure I’m using the right IP and the username (email) and pass are the same one I use to login into the My Cloud web

Here is the video
https://www.youtube.com/watch?v=HKeRGrj5jJ0

and the step by step by WD (something is happening between 3 and 4)

BTW. I’m using Mojave

It’s seems the option to mount with SMB is not an option for My Cloud Home.
The Upload and Download is extremely slow with the WD default setup.

My wireless speed is around 150mbs and I’m barelly hitting 7mbs with MyCloud Home, It makes it completely useless to my needs

Any help on how to optimize this situation?

My Cloud Home has two storage locations.
This article will help understand the differences and how to access the Public Share using macOS