I cant see the files after uploading them

Hi all,
i bought “my cloud ex2 ultra” a couple of weeks ago.

i have tried to upload file and folders several timme and i cant see the files after i finish to upload them.

for example - i have just tried to upload a photos folder. 100 files. i just can see 50 of them. the rest is there because whem i tries to drag a file from the computer to the cloud folder - it says that the file is already there but i just cant see them all… very strange.

Is there anyone here that knows how to solve it by any chance ?

thank you all !

How are you uploading files to your unit? Which operating system do you use? What happens if you overwrite those repeated files?

Hi !

I’m using Windows 10 OS. I uploaded the file throw the “network” folder. When i’m sliding from my computer to the cloud i can see all the files and folder, the problem begins when i’m not in my home network. when i go out and i try to log in via the mycloud.com - i can only see several files in each folder.

appreciate it !

Sometimes we need to ReScan or ReBuild the DNLA database in dashboard setting, and afterward reboot the NAS. Try this.

Hi, i have tried it but it does’nt work.
any other ideas ??

Thank you !



I have tried to slide to my cloud from other computers and it works.

Is there a possibility that the problem is in my computer or browser ? (chrome) Maybe something in settings ?

Thank you !