I can't change cover art like I could before


I’ve had the Live hub for about 3 months now, and so far it’s been brilliant. But in the last week or so I’ve been having a few problems with movie covers.

Before, after I transferred a movie file on to it, I would press the options button on the remote and do a search for content info. It would find the film, show me some cover art, a film synopsis etc. 

If I then accessed the Live hub via my PC I would see there would be 3 files for each movie: The AVI movie file; A JPEG image and an XML document. That’s all there was. Nothing else.

Occasionally the cover it found wasn’t to my liking so all I did was a quick google image search untill I found the cover I wanted and then I replaced the JPEG that was already on the Live Hub. Easy. And it worked every time.

The thing is that now, something has obviously changed. If I search for content info and look at the files via my PC, there are still 3 files (the AVI file and the XML document) but there is no longer a JPEG there. Now it has a METATHUMB File (?). Even if I copy a JPEG with the correct file name into the folder - it makes no difference. I cannot change the cover art.

Any ideas whats happened? Why has it suddenly changed? Or more importantly - how do I resolve it?

I’m not a technical person, replacing JPEGS was about my limit. But at least it worked. 

Any suggestions would be most welcome.



If you replace the .metathumb file with the jpg, then delete the metathumb file.

I’ve already tried that I’m afraid and iIt made no difference - the original picture still comes up.

But thanks for the suggestion. 

…and clear the cache by deleting the .wd-tv folder in the internal drive.

1 Like


It worked a treat. Thanks.