I can't access mybookworld on windows 7

I can’t map my wd network drive on windows 7.

I have the My Book World Edition (white light) model number WDH1NC network drive. It started giving me problems a while ago but I was able to fix it by remapping it because my ip address didn’t match. This time the ip address is correct and I am going crazy and have a major headache trying to figure out how to get my drive to work.

I uninstalled and removed the drive and updated the drivers thinking a clean install would help but it didn’t make a difference. I turned off the firewall incase it was blocking the connection, I made sure the drive shows up in the device manager, it shows up in the wd discovery tool, and I am able to login to the device manager online. I can get to the folder from my network devices but I get that message saying the folder can’t be accessed. 

When I try to map the drive with the WD software it comes back with an error message saying the network path wasn’t found, I tried to map both public and download folders and I tried using different drive letters. When I tried to map it through windows said Windows cannot access \mybookworld\public  Check the spelling of the name. Otherwise, there might be a problem with your network. To try to identify and resolve network problems click diagnose. Error code 0x80070035 - The network path was not found. I ran the diagnose troubleshooter but all it said was that the name was probably spelled wrong and it says the “mybookworld” exists but Windows can’t find “public” so I tried just \mybookworld and \mybookworld\download but they didn’t work either.

There shouldn’t be a problem with my router settings because it has always worked before using the same router.

I’d appreciate anything that could fix this error.

I am getting tired of trying to figure this out.

If anyone knows of a way to be able to connect it to the computer like a regular hard drive I’d be happy to do that if I cna’t fix my connection problem so I can at least get my files from the hard drive. Someone had mentioned if there’s no way to plug it into the computer than to take it apart and take the hard drive out of it so I am wondering what kind of hard drive is in it and would I be able to hook it up to the computer without any problems?

Thanks for any suggestions.

Hello kcerica, try following the steps from the link below to see if it helps. 


If the problem continues, you can try connecting the My Book directly to the PC Ethernet port and see if you can map it from there.