I cannot install WDSSDDashboardSetup in Windows 7 64bit

Hi,

I try to install WDSSDDashboardSetup with administrator account in my pc , and see this.

.

I just ran a quick installation on Windows 10 64-bit (Build 1607) with no issues. What happens if you download the latest version of the installer directly into your SSD from WD’s site?

i download the last version of WDSSDDashboardSetup , again the same as the picture. can you give me the msi , ι want to try to do a silent install with msi.

Unfortunately, I can only share files that are officially listed on WD’s site as direct downloads from WD’s servers. Additionally, non-media files can not be uploaded to the WD Community.

then find me a solution to the problem that I have with setup.exe file.

Try contacting WD Support about this. Try to provide as many details as possible with regards to the issue for proper documentation. They will contact you if they need additional information.

http://support.wdc.com/support/case.aspx?lang=en

this is not the forum for support? how contact with support?

No. The WD Community is a User forum.

WD Staff and personnel may post once in awhile, but the WD Community is intended for user-to-user support. If you need dedicated assistance then it’s best to reach WD Support through a direct communication channel.

The link to contact WD Support was provided in my previous post.

hi guys i got the same problem on win10 64bit
it keeps saying there an old version detected and the windows say it removing the old one to install the new one and its for 3hours now and still nothing

i never installed ssd dashboard before
i just did a clean install of windows 10 64bit
still the same problem

1 Like

Here is a quick fix: update the Windows 10 to the latest version. reinstall the app and install it again. Or remove the login password and run the program as administrator.

Hi,
It looks like that nobody cares.:frowning:
I have old Asus N73sv with WD HDD. Recently I have bought WD BLUE SSD 500Gb, migrated the data from HDD to SSD and tried to install for the FIRST time wdssddashboardsetup.exe from WD site.:frowning:
And guess what? The same thing : "old version detected"© and back off. And NO reply from SUPPORT with case [Deleted]
Could you be so kind to post the solution or workaround here if you find one.
Thank you in advance.

Best regards, Dmitry

tried on several laptops and pc’s same problem its bugged and wd dont do anything about it the sandisk does work
i have a dell latitude e5530 with al highest hardware in it i7quadcore 3th gen and tried to install it on an dell ispirion 5thgen laptop sameproblem

Just so you all know, we are working on a release to fix this as soon as possible.

I can’t launch WD SSD Dashboard after setup (error 0xc000007b). Somebody help me pls.Thx all.

Тhe same thing can’t install WDSSDDashboardSetup. windos 7*64

@ infergnome
I think the risk of reinstalling the system is too great , but how to remove the login password , i serach it on Google ,but get more tutorials on how to reset it ,