I cannot go back to wdtvlive_1.03.49_V firmware

Hi all,

I have been three weeks trying to guess what happened to my WDTV Live player and today I have realized that I cannot play movies through LAN connexion because of the latest firmware. That´s great!

Now I want to go back and I can´t.

Firstly I put the three files wdtvlive.bin wdtvlive.fff and wdtvlive.ver in the root directory of my WD hard drive! I turn on the player. I go to settings and I cannot find any upgrade icon as WD is reporting in the user guide (pag 163). Then I go to system and then press upgrade but the player only wants to upgrade online. Please help me as I cannot find any way to upgrade this device!

Thank you very much in advance.



Have you tried using a USB flash drive instead of a HDD?

Something else to check is that you actually have the right firmware:

1.03.49_V - for WD TV Live

1.03.49_B - for WD TV Live Plus

You can download them from here:


You need to download from that link because they have special VER files to ensure it’ll update.

…and I type too slow as I see Tony beat me to it :stuck_out_tongue:

Thank you for your quick reply. I´ll try and let you know if I manage to downgrade the player.



Hi all,

I have bought a KINGSTON DATATRAVELER 101 G2 PEN to try to downgrade the WDTV Live because using a WD harddisk didn´t work. But it seems this solution doesn´t work as I have formatted the PEN (FAT32) and placed the three files but nothing happens.




They are compressed inside a file called wdtvlive_1.03.49_V.zip I unzip the file and just put them in the root directory, WDTV Live reads the PEN when starting but the UPGRADE icon inside Settings doesn´t appear. I also tried to reset the device but I wasn´t able to get anything.

I would appreciate if someone could help me.



Are you using the correct ROLLBACK image?


Dear Tony,

I think so. I am downloading the file from that link. The file that end in V.



Quick test.  Go stick a few JPG files on the same stick.

Then see if the WDTV sees those photos.  If not, then there’s still something going on with your media.   If it CAN, then I have no idea.  :(

Oh, and a dumb question:   Are you SURE you have a “WDTV Live”, and not a “WDTV Live Plus”?

Make sure that the version number in the wdtvlive.ver file is newer than the version you are replacing…

Open the ‘wdtvlive.ver’ file with Notepad. You will see a line that reads: VERSION=‘1.03.49_V’. Edit the version number so that it is higher than the version you are replacing (Just change the 1 to a 2 so that the version number reads 2.03.49_V).

If you used the correct rollback version this should already be done, but it is worth checking.

Try using another USB stick other than KINGSTON DATATRAVELER. Once I tried to update my WDTV Live with a KINGSTON DATATRAVELER, but I could not. I know it is weird, but when I used another stick with exactly the same set of update files everything went fine.

SOME USB devices have a funky hidden “partiion,” called a Virtual CD.

Those things won’t work right with the WD boxes.

Does that apply to the Kingston Datatraveller?

DataTraveler is a thumb drive, Tony, not an external HDD. :wink:

But I’ve had no “it won’t work” problems using an el-cheapo 4GB Kingston DataTraveler 102 for upgrading and downgrading… it appears to be compatible with my Live (even if it is as slow as molasses in January).

ADD:  Maybe that’s it… have you tried leaving the Live alone for a while after you insert the thumb drive?  Give it time to find the files?  Because I know if I try to install b-rad’s firmware off the Kingston, it takes several hours, whereas it’s a few minutes off an external USB HDD.  Even the stock firmware takes ages to install once it’s found off the Kingston… perhaps you’re just not giving it enough time to find the files and see if they’re newer?

Thank youuuuuuu very much :slight_smile:

It worked flawlessly :slight_smile: I renamed the version to 1.04.11_V and WDTV Live immediately recognized the files as new. Now if I check the firmware, the device is reporting 1.03.49_V.

Now 1080p video streaming is working flawlessly :wink: with my MAC PRO, Airport Extreme and WDTV!!! 

Thank you very, very much for your help! :slight_smile:


RoofingGuy wrote:

DataTraveler is a thumb drive, Tony, not an external HDD. :wink:

Duhhh.  I know that.  :)

There are flash thumbs that do that, too.   I bought a copy of TurboTax a while back that came on a thumb drive…   The ADWARE was in a VCD and the regular stuff in the primary.  It was annoying.  I threw it away.  ;)

But there are many like that:


TonyPh12345 wrote:


Duhhh.  I know that.  :)


D’oh!  Im my haste I thought you thought it was an external drive. :cry:

I threw it away.

Don’t blame you. :smileyvery-happy:


I needed to revert to an older version of the Firmwear. I loaded in version 1.03.49 and now all my Video TS files play perfectly through the Network Connection to my Mac Pro connected through eithernet.

Here are the Firmwear files and instructions.