I can`t copy my wdmycloud onto usb samsung usb drive

ive tried backing up my wd mycloud onto several of my external usb drives (samsung -seagate) but cant . tried dropping and draggin but no luck please help ! using maveriks on imac 27 inch mid 2011. Thank you.

Is the USB drive connected to the mycloud? Or your computer?

Are you using Finder? or somthing else to copy the files?

I am not a mac person, what is maveriks?

any error messages?

ive tried both ,but realised it wasnt copying either way .Using finder .Mavericks is the latest osx operating system for Macs.

No error  messages at all . Method tried is drag and drop .Thanks . 

C`mon lads n ladies where are the WD experts ?

If I understand you have tried it with the USB disk connected to your computer, correct?

can you copy to and from your computer and the mycloud? If so I would say it is an issue with the USB drive

reformatted an external SEAgate and it`s working backing up my wdmycloud thanks larrygo and all others .  

Mine worked just fine, until I updated my firmware on my cloud. Now the Seagate drive is lost. THIS IS A LONG-STANDING WD PROBLEM!!!