I Can Not Access My Paspport Wireless Pro Through the Network

I have been reading through the forum for hours and have tried a few recommendations and still having issues. I followed the manual to setup the wireless pro. It is connected to our home WiFi, and shows in the file explorer under “Network”. However, when I go to open the MyPassport, by double clicking on the icon in Network, it just reroutes me to the Dashboard in a web browser. It does not open like a drive showing the folders.

The Pro works just fine when connected via USB, but we bought the device to be used between several in-home computers via WiFi. I used all of the basic settings, and I am running Windows 10 Enterprise. Are there some settings I might be missing?


Try opening Windows Explorer (not Internet Explorer) and on the address bar type \\ followed by either the name or IP address of the MP. If you’re not sure what the address/name might be, when it opens the dashboard have a look at the URL in the address bar to get those details.

I’m wondering if you would have been better served with a traditional NAS. If your PCs are all in the home and using WiFi, you don’t need the My Passport Wireless.

Now if you’re also taking it with you and connecting on the go, that’s a different story.

I am using windows explorer (not a browser) and tried that approach. It simply redirects me to the dashboard. Thanks.

Thanks, but we need it to be portable as we travel and have photos and videos that we want to back-up during our trips.

So when you type \\whatever\ in Windows Explorer (or File Explorer as it’s called in Win10), it opens Internet Explorer instead? That shouldn’t happen.

The Wireless Pro shows on my Windows Explorer as Storage.

When I double click that icon, it takes me to the dashboard.

Shouldn’t it just open like it does on the USB drive connection?

You probably using Windows home version. But anyway try reading online how to enable back the browing/sharing home network.


If you double-click on the icon it will take you to the dashboard. It’s one of the new “improvements” they made in Win10, which degrades operation a lot.

Typing \\MyPassport\ or \\\ in the address bar area should normally take you to the file list. Do not double-click on the icon.

Presuming everything is set up properly you need to use Win FILE EXPLORER, and be looking in the right place of program. I can see any of my wireless passports perfectly in Win 10 and 7.

You need to look in the far left vertical pane of FE under the NETWORK section where you will find devices on your network including your MPW by name. If you see MPW listed, great, you can access the contents. If you do not see it. click on (Refresh) curved arrow at top of window. Always place/keep the MPW near the router’s location for best wireless connection between MPW and router. Hopefully you see MPW in FE now. If not something else is wrong.

You also need a NAS for many reasons. Using MPW as a mini-NAS for irreplaceable data is foolish. Anything on my MPW is copied from data on my main NAS. If you lose or damage the MPW you will join the many people who have lost all their data.

I have similar problems with other MyCloud devices showing up under “computer” in the Network window.

In all cases, I access the device from the address bar using \mypassport or \ipaddress. All of the MyCloud devices have unique names and static IP addresses.

Theoretically, you can also access by mapping the device to a drive letter. I do not recommend that method because of RansomeWare concerns.

Using the MPWP as a travel backup device is also my primary use-case. In general, by the end of the trip all the files are on BOTH the MPWP and camera memory cards (32/64 GB cards are so cheap. . .why not?). The KEY is to ensure the MPWP and the memory cards are not travelling in the same bag. Backup to my home NAS happens shortly after returning home. To be honest, over the last year I have generally been replacing the MPWP with an external SSD drive in my work flow.