I am done with western digital and I suggest you not waste your time with them

I purchased an EX2100 and it was so slow it was practically unusable. For FOUR day’s now I’ve been trying to just find out if there is anything I can do to make it faster I have been passed around from person to person, given numbers that don’t connect and I am done. I no longer care about the product WD tech support is so utterly useless I am never using another of their products ever again and I advise anyone considering them to stay far, far away. Some of what I’ve gotten is . . .

I’m sorry we can’t do anything that complex call back between 8 and 10 when lvl 2 tech support is available from America.
I’m going to put you on hold . . . click beep, beep, beep.
I’m not sure who told you those hours but looking at my watch lvl 2 tech support is still on for another 2 hours and 45 minutes click beep, beep, beep.
This number doesn’t actually do that kind of work (same EXACT number I called the past 10 times and it did do that kind of work just not very well) use this one click. New number doesn’t connect.

Not to mention the sheer number of times I had to repeat information, if its this impossible trying to find out if there’s a way to make it faster which is a fairly simple enquiry I pity anyone with a more complex problem. This has been amongst my worst customer support experiences and has just cost themselves not only 1 returned product but also all future business from me.

EDIT
Content edited to abide by community guidelines.

Liam,
You joined this forum one day ago, and this is likely your first post. Why in the H**L didn’t you post in here first for some help?

I have a similar model to your device, a DL2100, and mine (and other’s) works fine. If we ever get to the bottom of your problem, I have a hunch the issue turns out to be “user error”.

Did you download and refer to the online user manual in the WD Support site? Tell me and other users your problem, and I’ll bet $10 one of us can help you.

Second post, first was asking about copying multiple files. I did search google for a solution first and honestly I thought a quick phonecall to their support line would be quicker and easier than posting here as I’d be speaking to them as I tried things. I was wrong.

I actually also think the problem is either (a) hardware based i.e. router just isn’t modern enough for high speed transfer via wifi (directly plugging the cabe in gets about 50mbs) or (b) some simple setting in either the router or the EX2100 that needs to be adjusted. That is the actual issue with the device is probably either minor and either simple to fix if you know what your doing or one of those “no sorry that’s the best you can get with your system.” The reason I’m so frustrated and angry is that trying to get help with this issue has been problem after problem after problem because of the customer “support” not the hardware and if I’ve had to go through this much to get nowhere for something this minor if it was a major issue I honestly think I’d rather just let my files burn than deal with WD’s support.

Still trying to put that aside so in response to your question yes I did download the manual and my problem is transfer via drag and drop the share folder in windows 7 using the wireless network is incredibly slow 1mbs normally with a high of 4mbs. If I plug in the ethernet directly to my computer I get about 50mbs normally with highs in the 60’s. So I’d like to know if there’s a way to speed this up and get the wireless transfers to happen faster so when I drag over a large file it copies in the 60’s or hundreds of mb/s some people seem to get. Alternatively I’d like to know for a fact that its a hardware issue and the only way to get it faster is buying a newer modem/router that’s better able to handle this.

So far I’ve updated firmware, reset the device using the hole in the back and then I got told anything more would take lvl 2 support who I initially couldn’t speak too because they were busy so I was put on hold, then hung up on, then told they’d call me back within 2 hours which they didn’t (with them no longer being available in either 1 hour or 2 hours 45 minutes depending on which person I talked too), then told I was calling the wrong number and given one that wasn’t connected to call.

Just hold off trying to move big chunks of data at a wireless snail’s pace until sometime on Friday, and after I get back to you. We can speed things up to gigabit speed and you won’t need an expensive new router to do this! Unfortunately, I don’t have time to go into detail now. And no more rebooting, resetting or firmware upgrades for now or calling WD support, for that matter. I just request you be patient and not get anymore frustrated. Relax.

I’m relaxed, I’m calm. As I said the device itself is fine and currently plugged in via ethernet cable to back up (I payed for the thing so I"ll use it). Plus I bought a seagate 2 TB which is also working fine.

Hi Liam_Warner, as you mentioned in one of your post, most likely the issue is with the wireless speed than with the My Cloud, I have a EX 2, on my network and my router is a Archer C7 with AC and My Computer can handle AC connection as well, and I am seeing above 20 MB/s.

Liam,
I am back to help you. First, we need to understand your file transfers will only be as fast as your slowed device in the chain.
In my case, all my devices run at gigabit speed and through wired connections. This includes my router, My Cloud NAS, Windows PCs, and network switches. Plus, I have one the fastest My Cloud devices; a DL2100. It is rated to transfer data at up to 115 MB/sec, and I consistently get 113 MB/sec.

OK, so you need to know for sure if your Win 7 PC has a gigabit wired network capability; mine does. Check the specs of your PC. Assuming it does, we know that your My Cloud can run at gigabit speed; again check your specs. If both these conditions are met, AND your PC and My Cloud are close by one another so that can connect them together with a gigabit network switch, you have met all conditions. These devices are used to connect multi Ethernet connectors together so you can use more than the single Ethernet connection.

What you do for large data transfers is to disconnect your router from the two devices and plug both the PC and the My Cloud into the same gigabit network switch which enables transferring data between them at gigabit speed. These switches are not very expensive, and price depends upon brand and the number of ports on the switch. The smallest one has 5-ports, and since you only need two ports, you can get this size.,

I have a wired home network through my house with four rooms having an Ethernet wall jack, and I have either the 5 port or 8 port switches connected to each wall jack so I can plug lots of devices into my network.

This is a link to the brand switch I have and where I bought it from at Newegg.com This model costs $19.99. Other networking companies like Netgear, Cisco sell these gigabit switches, too, and can be found at most any computer store like BestBuy , Fry’s etc. if you want to buy one right away. Expect to pay a good bit more from a store.
http://www.newegg.com/Product/Product.aspx?Item=N82E16833156250

Once you get a switch and set it up as I described and have your large data transferred finished, get back to me and we can discuss your getting a new dual-band gigabit router with fastest wireless speeds. You will need one.

PC LAN network at least say’s gigabit as does the big silver startup screen. The wireless seems to be only able to support up to 300mbs I think but that’s still better than 4.

We do not care about the wireless speed right now. You are not going to use wireless with a wired network switch. You have to use Ethernet wire to connect your PC and My Cloud to a (powered) gigabit network switch. Read what I wrote about this again.

Once you are finished transferring all your Win 7 data to My Cloud, you will remove the network switch and put your system back as it was before. You will again use wireless to transfer individual files from PC to My Cloud again, but not big blocks of data.

I got a call today as someone at WD made a case file, the guy had me delete the users and recreate them now when I try to connect via cable it can’t discover the drive and say’s "Unable to sync ‘WDMyCloudEx2100’, user has been deleted. To resume syncing with ‘WDMycloudEX2100’, go to Settings > Folders to remove the drive and then add it back again. Any idea how I can fix this one? It also wont connect in the PC WD my cloud app it shows the device but it wont connect to it. I had hoped it was because he made it a static IP and turning it back to autoassign would fix but no.

Two different issues/solutions; mine and WD’s. I have no idea why they had you do all that; sometimes I wonder about their support folks. Look, you don’t need a static IP; that is often chosen as a “solution” if someone can’t figure out stuff. I have a good router, it assigns IPs correctly, and I have NEVER needed to set a static IP for any reason even though there are over 30 devices connected to my network.

First of all you have not likely tried my suggestions yet, hopefully, so you say you are connected to your network via cable. Do you have internet access? You need it for when setting up the My Cloud from scratch. Be sure you do.

Let’s try to get you back where things worked better – better than now. Do a Factory Restore, using SYSTEM ONLY. the other methods in Restore will erase your data, and you do not want to do that. So, from Dashboard, go into Settings/Utilities and select Restore to Defaults, and in here is where you select System Only, and do it.

After it completes restoring and completely reboots you will be back at Dashboard entry, use the default name (admin) and NO password to get into Dashboard. Put in your password again if you like now, and skip setting up users for now. Just see that all the basics work as before. Perhaps you may need to turn on DLNA streaming again, etc.)

From what you have told me, your big problem is trying to use very slow wireless to move big amounts of data, and once you get the gigabit switch and use it to move data faster, things will improve. Otherwise, until then I can’t be much further help. I want to know you did this and that things improved. Best of luck.

Nope not tried your advice mainly because I’m currently looking for a new modem/adaptor card as we’re gettting the NBN put in next week or week after (australia) so I’m looking at reviews and the like then intend to buy the lot (router/card/router switch). The router switch for now to try your advice, the others for the NBN. Its a matter of what the local stores are carrying vs what’s recommended/price. Its also possible I’ll just go for a better switch and get that put in to run a better Lan. Not rushing into a purchase anyway. I’m also assuming since you went to the effort of suggesting it that a gigabyte switch would actually be a better option than plugging the ex directly into the computer via an ethernet cable.

Your not the only one wondering about their “support”

Thanks for the help at least now I’m back to where I was with it transfering over at 8MB/second for the smaller files and 55MB/S for the video ones. Of course I should be getting better than this considering its a cat6 cable going direct from the computer to the ex and both of those are gigabit ethernet capable. Still we’ll see how it goes when I get a switch.

One cannot judge network speed by small file (music and photo) transfer They end almost before they begin. One needs to transfer at least files a gig or larger so the transfer lasts long enough that things “rev up” enough for a true reading. 55MB,sec sounds like a decent speed if you have the PC and My Cloud directly connected to one another. I never needed to do this, although I do feel it is “safer” for both devices to be connected through a network switch rather than directly to one another. My opinion only

If you get a new router, get a Gigabit speed one with at least 450mbps for both 2.4G and 5G signals. It appears you may be using wireless often, and you need top speeds for that. A top rated router of the last few years is the ASUS RT-N66U, which has come down in prices since the newer AC speed routers appeared. Not too many devices are using AC speed even today. One familiar to me that I have is my two-year old HP laptop, and the newest iOS devices, have it too. But, I use wireless only for mobile devices in most cases and my older iOS devices work fine on 5G. I don’t need a new router yet, but if I did, I would buy an AC capable one just for some future-proofing today. ,

The one I was looking at was the asus RT-AC68U right now https://www.asus.com/au/Networking/RTAC68U/specifications/ 600 for the 2.4GHZ channel and 1300 for the 5.4 one. Along with the PCE-AC68 adaptor for the desktop. About 340 for both.

Sounds good.

I’m still getting an "Unable to sync . . . " I have no idea what it means by go to settings > Folders to remove the drive and add it back again how do I do that?

Never saw this, so have no idea. Even the sentence structure makes no sense, Is it some sort of Aussie English, or did you just screw up typing? :wink:

We have the same user manual, and I searched it for sync, and it mostly relates to backups. Why don’t you search it, too.

You may have to do one of your favorite things on Monday – call WD Support! If you do, be patient with the level 1 person, but if you are not getting anywhere, ask to be moved up to a level 2 support person. I know the time diff makes things diff calling the west coast of US, but that is where level 2 folks mostly are located.

Sentence is typed out directly the same as WD’s notification. I’m not calling WD support I’ll just take my chances with uninstalling various programs till it shuts up. I couldn’t find it in the manual either which is why I was hoping it’d be something you’d recognize.

This is the part of msg that confused me; "what it means by go to settings > Folders to remove the drive and add it back again " where are these Folders in Settings it is talking about? Got me.

Me too.