Humax HDR-Fox T2 .ts files won't play

… on my WD TV Live?
Did a few weeks ago but not now… anyone know why this might be?

Want to play Humax .ts SD or HD TV video files (saved to USB external hard drive) on my WD TV Live or similar Media Player to another TV…

Any help very much appreciated?

Use MediaInfo to analyse the file and post your results.

… sorry but I don’t understand how that helps me?

Shouldn’t the WD TV Live play my Humax .ts files, or are there good reasons why it might not… ? Surely I am not the only one here to experience this problem/issue :frowning:

The mediainfo helps us to help you.

WD-40 wrote:
… sorry but I don’t understand how that helps me?

Shouldn’t the WD TV Live play my Humax .ts files, or are there good reasons why it might not… ?

It totally depends what’s in the files… that’s why we need to see the MediaInfo.

Pretty much any video stream and any audio stream can be packed into any file type (whether the “standards” allow for it or not).  The Sigma chips in the WDTV family will play back certain video streams – not everything that exists.

Confirming exactly what the video (and audio) stream’s settings are within the .ts file, allows us to see whether the WDTV is doing something wrong, or whether it’s just a type of encoding that the chip can’t decode.  If it’s the second one, there’s pretty much nothing anybody at WD can do to get the files playable… the only answer would be for you to re-encode the video into a supported stream.

Your last post was blank.  If you’ve switched to IE9, you need to set the “Compatability Mode” as described in this post:

1 Like

Many thanks RG, now I can post ‘properly’…

… I wanted to ask - how is it possible for me to use MediaInfo when the (Humax) formatted ext3 USB hard drive files cannot be seen on my Windows (7) laptop?

The MediaInfo app is available for just about any OS from the link Tony provided – it’s not Win-only.

You should be able to run it on whatever OS you’re accessing the ext3 drive from.

I have the MediaInfo app but I can’t see the files on the ext3 USB drive… they were created on my Humax, where they can be seen.

My confusion… I’m with you now… I thought you also had Linux/Ubuntu, and that’s why the drive was ext3. :wink:  I was thinkin you could just run the Linux version of Media Info.

But I get you now.


It’s an ext3 driver for Windows… your Win7 laptop should then be able to read the files on the ext3 drive. :smiley:

Wait a minute, tho… how are you connecting the ext3 drive to the WDTV?

The WDTV doesn’t support ext3… it will ony work with NTFS, FAT32, HFS and HFS+ drives, I thought.

Is there a chance you used to have the WDLXTV third-party firmware installed, and your “can’t play” problems showed up around the time you changed to stock WD firmware?

Or am I just more confused than ever?  :smileyvery-happy:

1 Like

My WD TV Live opens and shows the files, type .ts and file size - but doesn’t play.

Have since been advised that the Humax HD video .ts files are encrypted and the SD files are encoded, although the latter have no need to be and this encoding might be removed in a future update?

I also now understand the encrypted HD files (certainly) can only be played on the Humax machine on which it was created, not sure about the current state SD files!!

Have had a bit more time to follow-up on some good advice here, using Ext2FSD I added an ext3 partition on my Windows 7 hard drive - which enabled me to access the Humax videos on my LaCie Rikiki USB hard drive.

As suggested I used MediaInfo to get info from this short Family Guy (SD) .ts video as an example of the files I cannot play on the WD TV Live… as I pointed out on my preceding post it seems even the SD videos are encoded, although I don’t know if the following confirms that…



ID                               : 4173 (0x104D)

Complete name                    : G:\Family Guy_20110508_0257.ts

Format                           : BDAV

Format/Info                      : Blu-ray Video

File size                        : 389 MiB

Duration                         : 21mn 3s

Overall bit rate                 : 2 581 Kbps


ID                               : 301 (0x12D)

Menu ID                          : 4288 (0x10C0)

Format                           : MPEG Video

Format version                   : Version 2

Format profile                   : Main@Main

Format settings, BVOP            : Yes

Format settings, Matrix          : Default

Format settings, GOP             : M=3, N=24

Codec ID                         : 2

Duration                         : 21mn 3s

Bit rate mode                    : Variable

Bit rate                         : 2 212 Kbps

Nominal bit rate                 : 15.0 Mbps

Width                            : 720 pixels

Height                           : 576 pixels

Display aspect ratio             : 16:9

ActiveFormatDescription          : Letterbox 16:9 image, with alternative 14:9 center

Frame rate                       : 25.000 fps

Standard                         : PAL

Color space                      : YUV

Chroma subsampling               : 4:2:0

Bit depth                        : 8 bits

Scan type                        : Interlaced

Scan order                       : Top Field First

Compression mode                 : Lossy

Bits/(Pixel*Frame)               : 0.213

Stream size                      : 333 MiB (86%)


ID                               : 302 (0x12E)

Menu ID                          : 4288 (0x10C0)

Format                           : MPEG Audio

Format version                   : Version 1

Format profile                   : Layer 2

Codec ID                         : 3

Duration                         : 21mn 3s

Bit rate mode                    : Constant

Bit rate                         : 256 Kbps

Channel(s)                       : 2 channels

Sampling rate                    : 48.0 KHz

Compression mode                 : Lossy

Delay relative to video          : -264ms

Stream size                      : 38.6 MiB (10%)

Language                         : English


ID                               : 305 (0x131)

Menu ID                          : 4288 (0x10C0)

Format                           : DVB Subtitle

Codec ID                         : 6

Language                         : English


ID                               : 300 (0x12C)

Menu ID                          : 4288 (0x10C0)

Duration                         : 21mn 3s

List                             : 301 (0x12D) (MPEG Video) / 302 (0x12E) (MPEG Audio, English) / 305 (0x131) (DVB Subtitle, English)

Language                         :  / English / English

I copied that Family Guy .ts video from the USB hard drive to my laptop, then trimmed start & finish in Windows Live Movie Maker and saved as WMV … hoping I might be able to at least play that (Humax SD) video on my WD TV Live?

No, it was “having none of it” as they say… :neutral_face: … !

I can only guess this is due to licensing issues, never mind that it’s not even HD and I had edited it etc etc…

… btw - I should add that I had saved the Family Guy ‘test’ file to my usual (non ext3) LaCie Rikiki hard drive for attempted playing on WD TV Live!

If you edited it and saved it as a wmv don’t forget that the WDTV will only play certain wmv files. You must make sure that you save it it as a WDTV supported type.

1 Like

I have been so caught up with the Humax files, but failed to check the obvious … none of my  videos will play on the WD TV Live?

Plugged the particular USB hard drive (that I have been using long before I bought the Humax) into my laptop to check it’s not a hard drive issue and the videos play fine - apart from the MKV movies and clips which I could only play on the WD anyway…

I have tried copying a few small video files onto my Scandisk USB memory stick and they don’t play on the WD TV Live from that source either.

Does anyone here have a clue as to what the problem might be - and indeed if it can be fixed…please?

Try the 3-step mega-reset and see if that makes any difference…

  • unplug the WDTV for 10 minutes
  • when it powers on, press the paperclip reset button
  • when it reboots, choose “Reset To Factory Defaults” in the settings
1 Like

… I thought that might be the advice, thank you for your quick response RG - will that need to be followed by the latest firmware upgrade, or upgrades?

Should I make notes first of any System Info - MAC, IP address and the like?

Yes, it’s advisable to make a note of your IP settings if you’ve set them manually, so that you can enter them again easily.  If they’re obtained automatically through DHCP, you shouldn’t need to worry about them – it should just automatically obtain new settings, just like every other time it’s powered on.

Unless you’re trying to play .mkv files that have header compression, and using an old version where this bug was not yet addressed, the firmware version shouldn’t really matter… a playable .avi should play under any firmware… a playable .mpg should play under any firmware… a playable .mkv should play under any firmware.

If the resets don’t help, then you could try updating or downgrading your firmware and see if that changes anything… but for now, just stay with your current firmware and see if the resets help with your issues.

1 Like

Well, seem to have got to the bottom of all this!

I only did the paper-clip reboot, and then played an assortment of videos from the ‘original’ NTFS Rikiki USB hard drive… all back to normal!

Then I connected the ext3 USB hard drive and it played the Humax SD .ts files ok - but when I selected an HD .ts file it refused to play ball… it then also refused to play the SD files!

I reconnected the ‘original’ USB hard drive and the WD wouldn’t play any videos.

After rebooting again everything was fine… tried the ext3 USB and all well until I tried to play an HD .ts video, no go!

Did another reboot and again everything back to normal.

Seems every attempt I made to play the (encrypted) Humax HD .ts file it down-tooled and refused to play anything else from that moment on!

Obviously I will only play the Humax SD videos (now stored on my blue Rikiki) and will keep the Humax HD stuff on a ‘dedicated’ red Rikiki… as things are I won’t attempt to play those on the WD.

Thanks for your help over this … it seems the attempt to play the encryped files corrupted the WD in some way?

1 Like