Hulu Plus will not play

I log in to hulu plus just fine, it plays the commercials at the beggining then attempts to load the show, I then get there error “we;re sorry, but there was a network connection issue while playing this video. Please check your connection and try again” however, my pc works fine, pandora works fineon the wdtv, i don’t have netflix to check that. . . anyone have any ideas?

oh and I tried rolling back the firmware and manually updating, didn’t make any difference, also tried resetting to factory defaults, no differenance. . . I am totally confused. . . 

UPDATE: Netflix works as well

everything else on the device works fine, I did find some posts for other devices saying to try alternate DNS manually in the router, this did not help, I have tried rolling back than manually reloading the new firmware, then I tried the reset button on the side of the device, still nothing. . . I have found posts saying something about flash not being the right version when watching in a browser causing the same issue. . . looking into this now. . . if anyone has any idea how to fix this please respond.

I get the exact same error.
Everything else works except for Hulu.
When I unplug the network cable and plugin PS3 instead, Hulu Plus works there without a problem.
So it really is not my network.

I first got this with the WD Live Hub. After troubleshooting it for a week, I gave up and got WD Live Plus instead.
It didn’t make a difference, unfortunately.

Yes, I’ve got the exact same issue, using the latest firmware.  My Hulu Plus account works fine on my phone, so the account is OK - and Netflix works on the WD TV Live Plus HD box, so it can access some things on the internet - but all I can play on Hulu is the first commercial, then it says there is a network connection problem.

My WDTV box is behind a firewall - could this be an issue of needing to open one or more ports for forwarding?  If so which ones?  Can’t seem to find good info on this.

I hate to be one of those “I have the same problem” posters, but here I am.  Mayve fresh activity on this post will attract attention.

FW = 1.07.15

It played Ok with this FW for at least a month until yesterday.

I get the commercials just fine.  My PC has no problem playing The Daily Show…

Pandora works OK.

I restarted the system; I changed DNS servers on my router, no luck solving the issue.


Found the solution: I had increased firewall security level on my router from low to high.  Hulu Plus was working on my PC-- I guess the WD implementation uses different ports?  Back to “low security” and the WD is back in business.

(Router = Verizon DSL/Westell 7500)