Hub ejects powered USB hd in the middle of a movie and turns it off!

This is a weird problem that I recently discovered - The hub seems to eject my powered USB hd (Verbatim External 3.5" Hard Drive 1.5 TB model #47513) in the middle of a movie if there’s a longer pause(black area).

It happens in movies that I know have worked perfectly before, I’ll try to describe exactly what happens:

Whenever there’s a pause of a few seconds where the screen turns black, the hub makes a clicking sound as if it is switching something, then shortly after it turns the power of my Verbatim hd and gives me a message that the content source is no longer present!

Things I have tried to locate the problem:

  • Attaching the verbatim USB hd directly to my TV
    No problem the movie plays fine through the pause
  • Re-ripping the movie to mkv
    Does not solve the problem with powered USB hd and the hub
  • Playing the movie from an USB powered hd (Packard Bell PB GO 2.5" 500GB model#LC.EXH04.015)
    The hub still makes a clicking sound during a pause(black screen) in the movie, but it plays the movie just fine to the end
  • Attaching the verbatim USB hd to our old media player (Denver dcb-108hd - DVB-C TV-tuner with media player function)
     No problem the movie plays fine through the pause
  • Playing the movie using DLNA on my TV through Twonky server on the hub
    Same problem - The verbatim USB hd is being powered down during pause in a movie(black screen) 

I’ve got a few movies that used to play fine, but now have the same symptoms, and it is at the exact same spot (during a pause in a movie(black screen) - Re-ripping them does not help!

I am not sure, but I think the problems began after the 2.06.10 firmware update!

The hub is beginning to drive me insane, things seems to get worse over time, I am very close to give up on this device!

Please, if you have any suggestions that might help, do not hesitate to post them here!

A couple of things to try:

What happens if you play it from the internal HD?

Also, try rolling back your firmware.

Thanks for the suggestions Tony.

Tried copying the movie to the internal hd of the hub, result was that the movie played fine!

Rolling back the firmware is something I’m gonna try when I get the time to do it, I’ll let you know the result when I’ve done it!

It’s been a long time since I made this post, but I thought why not post my solution in case others had similar problems!

The problem wasn’t the hub, but rather a power saving strip where my TV is the master and when the hub made that clicking sound as if something changed in the output - That actually made my TV turn off all other devices plugged into the power saving strip, and that is where the usb hd got the power from!

SOLUTION: Exchanging the power saving strip with an ordinary power strip made the problem disappear - Sometimes a solution is right in front of your nose that you don’t see it :smileyvery-happy:


The Clicking sound you hear was probably just the drive parking.   A few hundred mW of power being reduced.