Hub- blinking light and Shut Down

Last night I was watching a movie through my hub, but had to stop in the middle to put the kids to bed. I shut the hub down completely during this time( about a half hour). When I was free to watch the rest of the movie, I started the hub back up and I noticed a strange flicker on the tv screen (Mits 55" widescreen projection) then the screen turned blue. At this point the hub began flashing its light at me. A minute or so went by and then the hub shut off. I could turn the Hub back on but everytime (about 5 times)the light would just flash and then shut it self off.  I have my Hub connected to my tv with component cables as my tv is way too old for HDMI :-( 

Knowing my tv as I do, I know that a blue screen means no connection so I pulled the componant cable off my hub and hooked it up through composite. I was surprised to see I had connection. I went to the video settings and I noticed the output was switched to composite so I switched it back to componant , rehooked the cables and was back in business watching my movie in 1080i.

Now, I am 100% positive the video output was on componant originally and I (nor anyone else) did not switch it to composite. Strange but true! 

Hi there, the Hub tends not to remember its settings at a random moment, so I see where you’re coming from :slight_smile:

I have been using the hub for about a month, recently as I was watching a movei I received a call so I put off the hub. Again when I tried to restart the hub, the hub  would start,  the logo would appear on the screen then the logo would go off with a flash of light then again the logo would appear and the light on the hub would start blinking and then the hub would shut down.  As per customer care I downloaded new firmware as a zipped file, unzipped the files and through a pen drive tried to load it into the hub, however the hub it seems did nor recorgnize the firmware. Any suggestions? please suggest, thanks

There have been a number of reports on various forums with similar symptoms. You will not be able to flash the box  if the box does not boot to the splash screen.  I would return the box to the place of purchase for a warranty exchange.

1 Like


You should check out the thread HERE, which sounds like the problem you are having.

I had the same issue after using the device for about 4 months. It suddenly kept shuting off all the time. I send the device via RMA back to WD. I got a replacement drive within a few days only.
Surprisingly when I tried to register the replacement hub online, it registered as a harddrive only, saying that the serial number is not valid (which was the serial number stored in the firmware!) . Upon manual registration with the serial number from the bottom of the device, the warranty was reduced to a few months only, where my original device still got a warranty until April 2013. 

But the worst thing is, that the replacement device showed the same behaviour after only two days of use !!!  

Contrary to what it was said in this post: 

there is no fix at all or they have sent me another faulty device.
It seems to me that the Live hub has a major hardware problem and WD should publish a recall of this product.

It is disappointingy as it took hours to fill the harddisk again with my media data and now it is useless already. I won’t perform the workaround which might be to disconnect the power button as others have posted. I want a fully functional device!

I will try to contact WD personally now and discuss how we can solve the issue.