Hub becomes unresponsive and requires MULTIPLE reboots to work again

Since the last software update, I have had to unplug and reboot my Hub at least once every two days. Usually, I need to unplug and reboot the machine two to four times before the unit becomes operational again.

The unit works fine, but if it’s left on, it will eventually stop working. When I turn on the HDTV, there’s no signal from the Hub, and neither the power button on the remote nor the power button on the unit itself works. I think the problem is somehow related to the Netflix app (or whatever we’re calling them). Unless you return to the home screen after watching a program, the unit eventually becomes unresponsive.

Last night, the unit stopped responding to either the remote or a wireless keyboard I use with the Hub. I don’t know whether this bug is connect with the one I just described.

The only solution to both problems is unplugging the Hub for several minutes.

I understand technology can be fickle and am not surprised that the unit would need rebooting occassionally, but this is becoming an everyday occurrence.

My questions:

  1. Is anyone else having this problem?

  2. Is there a software patch that will fix it?

  3. Is this problem indicative of a hardware failure?

Thank you.

Have you tried the overkill reset.

Reset via the bottom paperclip button. Press for a couple of seconds and then release with the unit fully booted up.

Reset to factory defaults via the internal menu.

Unplug from power for some minutes (not seconds)

Do all 3 one after the other.

Note: You will lose any Get Content info that you have downloaded.

1 Like

Good advice, richUK. I immediately noticed some improvement in closing out apps. Hopefully, this has solved the larger issues, too. Again, thanks, richUK!

It didn’t solve the problem. It worked earlier, but just now, my daughter finished watching a show on Netflix and left the Netflix app running but turned off the TV. When she turned the TV back on a little later, we had nothing but a blue screen. The power button was unresponsive. I unplugged the device for a couple minutes, plugged it back it back in. The power light came on and flashed but, still, no signal. I had to unplug the device and plug it back in a second time before it would work.