Hub as a DLNA server doesn't show all the files

Hi. In my home i have a WDTV Live Hub in the playroom which I use for music/videos on the tv and for streaming data to a WDLive Streaming in my bedroom.

after the latest firmware upgrade, when I connecto to the Hub via DLNA (from the streaming or ipad) I can’t see all the folders containing the videos, I can see just 2 of them.

To be clear: in the folders video I have 4 subfolders: Movies, Series, Music and Kids. I can see all of them from within the Hub, but from a remote device using DLNA I can only see Music and Kids, I don’t see Movies and Series. That happends regardless of the remote device, I tried it from the samsung smart tv, the WDLiveStreaming and iPad with the same results.

Any ideas of what can be wrong?

thanks for your help

Start by re-building the DLNA database.

Go to the Twonky UI by surfing to:


where x.x.x.x is the IP address of your hub.

Select the Maintenence section, and do “Rebuild.”

I did a “clear Media Library” from the menu, but it didn’t solve the problem. is that the same as say?

Thanks for Your help

That’s not the same thing, you have to access the Web UI, by typing in the HUB’s IP address in your browsers address bar on your PC.

Then access the Twonky UI.

This can’t be done from the HUB you have to do it from your web browser on your PC.

I tried that but didn’t work, the rebuild freezes processing one folder and doesn’t go any further.

I even left it overnight but didn’t work, it’s still at the same place.

I tried moving the videos to a different folder, but no avail, it keeps freezing.

any ideas of what can be wrong?

thanks for your help

even worse, sometimes after I try to rebuild the database, twonky crashes and I cannot connect to it with a browser and I need to restart the hub