How you can find what is causing the problem with network sharing


#1

Hopefully this will help people find what is causing the error on their network with the live.

The first thing you need is a program called wireshark. Wireshark is free and will install a driver that will allow the program to view all the traffic that is on your network. Download is here:

http://www.wireshark.org/download.html

Run the program and  start a new capture. It will show a screen with a bunch of colors and text scrolling by, this is all the traffic on your network. Below I have listed what every WDTV Live box will do when it is plugged in regardless of the network.  These are the things to look for in wireshark.

0.0.0.0    255.255.255.255    DHCP    DHCP Discover    ---- Live asking for an ip address

WesternD_74:26:68 Broadcast  ARP  192.168.0.6  is at  00:90:b9:24:86:18  ----  Live has an ip now 192.168.0.6

WesternD_74:26:68  Broadcast  ARP  Who has 192.168.0.1?  Tell 192.168.0.6 — Live  asking for router IP

192.168.0.1 Broadcast ARP 192.168.0.1 is at 00:12:a8:07:b3 – - router telling live where it is

The ones below are the most important for file sharing. This is where the live starts looking for a net bios name server.  The ip on the left is the one sending out information.

192.168.0.6    NBNS    Registration NB WDTVLIVE<20>

Not finding a workgroup named WDTVLIVE it starts the sequence below:
192.168.0.6       NBNS    Registration NB WORKGROUP<00>
192.168.0.6       NBNS    Registration NB WORKGROUP<1e>

Until it finds the  browser for the network :
  192.168.0.6       NBNS    Name query NB <01><02>__MSBROWSE__<02><01>
  192.168.0.6       BROWSER    Host Announcement WDTVLIVE, Workstation, Server, Print Queue Server, Xenix Server, NT Workstation, NT Server, Potential Browser, DFS server

And finding it attempts to become part of it:

  192.168.0.6   MDNS    Standard query ANY WDTVLIVE.local
  192.168.0.6   IGMP    V3 Membership Report / Join group 239.255.255.250 for any sources
  192.168.0.6   IGMP    V3 Membership Report / Join group 224.0.0.251 for any sources

Right after that my pc at 192.168.0.3 replies asking for where on the network this WDTV Live box is ?

  Giga-Byt_9c:98:4b    Broadcast    ARP    Who has 192.168.0.6?  Tell 192.168.0.3

The Live box replies with its location on the network:

 WesternD_74:26:68    Giga-Byt_9c:98:4b    ARP    192.168.0.6 is at 00:90:a9:74:26:68

My pc tells the Live box how to access the shares, The WDTV box now has the information on where the files are and what ports to use but has not tried to login yet.

192.168.0.3    UDP    Source port: 54543  Destination port: 56087
192.168.0.3    UDP    Source port: 54544  Destination port: 56087

Now when I go to access a share from the Live , the box alerts the pc it wants to do something
192.168.0.6    TCP    60827 > netbios-ssn [SYN] Seq=0 Win=5840 Len=0

The pc replies back that the Live has its attention:
192.168.0.3   TCP    netbios-ssn > 60827 [SYN, ACK] Seq=0 Ack=1 Win=8192 Len=0 MSS=1460

The Live tells the pc that it wants to open a session:
192.168.0.6   NBSS    Session request, to WORK-PC<20> from WDTVLIVE<00>

The pc tells the Live it is ready for a session:
192.168.0.3  NBSS    Positive session response

Now is where the actual sharing starts, they first try to agree on the language of the conversation:
Live tells pc what it can understand

192.168.0.6     SMB    Negotiate Protocol Request

And the pc responds whether it can accept that as the common language between them.
192.168.0.3    SMB    Negotiate Protocol Response

Now that they agree on how to communicate the live tries to setup and request a login on the pc
192.168.0.6    192.168.0.3    SMB    Session Setup AndX Request, NTLMSSP_NEGOTIATE

workgroup is the group and my username on the pc is wdtv so it uses that as the login username
192.168.0.6    192.168.0.3    SMB    Session Setup AndX Request, NTLMSSP_AUTH, User: WORKGROUP\wdtv  

The pc accepts the login
192.168.0.3    SMB    Tree Connect AndX Response
192.168.0.3    SMB    Tree Connect AndX Request, Path: \192.168.0.3\External  – - location of share on my pc

Live asks for file system information from the pc
192.168.0.6  SMB    Trans2 Request, QUERY_FS_INFO, Query FS Device Info
192.168.0.6  SMB    Trans2 Request, QUERY_FS_INFO, Query FS Attribute Info
192.168.0.6  SMB    Trans2 Request, QUERY_PATH_INFO, Query File All Info, Path:

Most people will find the problem before this point, you should be able to see the files on the live by this point.

When you to select a file on the LIVE to start playing it will then  request the file name and info
SMB    Trans2 Request, QUERY_PATH_INFO, Query File All Info, Path: \tvseries\Bones.S04E04.avi
SMB    NT Create AndX Request, Path: \tvseries\Bones.S04E04.avi

The pc sets up a transfer for just that file:
192.168.0.3   SMB    NT Create AndX Response, FID: 0x4000

And the Live starts asking for the file data:

192.168.0.6    SMB    Read AndX Request, FID: 0x4000, 16384 bytes at offset 0 

The  file starts transferring or playing to live hardware, you will see tons of these as each is just a packet of data:
192.168.0.3    192.168.0.6    TCP    [TCP segment of a reassembled PDU]

If you get that far everything should be working . The most likely problems are at the start where the login occurs.


#2

I’ve downloaded wireshark and will definitely be looking into this.  thanks for the info.


#3

I

AnthonyB wrote:

I’ve downloaded wireshark and will definitely be looking into this.  thanks for the info.

If you need any help just send me a message and I will try to assist. Good Luck !


#4

See my issue here.  When I run Linux (Ubuntu 9.10), I can access the WD Live local drive (16GB Sandisk USB flash drive) without any problem. I switch to Windows 7 (exact same hardware and network connection) and it fails miserably.

Note that I don’t have a problem viewing the media from WD Live once it’s on the USB flash drive, that works fine, it appears to be some incompatibility when accessing local drive on the WD Live through Windows 7.   I haven’t tried any other version of Windows.

Network streaming (i.e. from my PC to WD Live) is working fine, but the reason I bought the WD Live was so that I could load up a USB flash drive through my home network without having to stream content.

I had another go last night, and the only new clue that Wireshark throws up seems to be some STATUS_NOT_SUPPORTED errors.