How to update Plex App on My Cloud Ex2 Ultra

Hi there,

I have the My Cloud Ex2 Ultra and am running the Plex Media Server app to streams movies etc. How do I update the Plex server app or confirm that the app is running the latest version on my NAS device?

I have been linked to and downloaded a .bin file as the latest version of Plex. I am using a Macbook pro to access the My Cloud through a Chrome browser.

Thank you!

Hi jackwagon13,

You can follow the steps given below to update the plex manually on your My Cloud EX2 device.

  1. Open your My Cloud User Interface.
  2. Navigate to the Apps Page.
  3. Select “Add a new App” (the small box with a “+” on the lower left.)
  4. Select “Manually add a new App.”
  5. Navigate to where you downloaded the update file (*.bin).
  6. Select the *.bin update.
  7. Follow instructions from there.
1 Like


I would also like to manually update my Plex server as I currently cannot play media files (I used to be able to). I have downloaded the BIN from Plex and am ready to go,but I have an issue.

I can do steps 1-4 with no problem. When the Terms and Conditions pop up (would be step 4a) I click the “Accept” button, but nothing happens. The button turns blue when clicked, but it does not let me proceed.

I am running the latest firmware (WD My Cloud EX2 Ultra Firmware: 2.31.149). I have rebooted the NAS and that hasn’t helped. I have tried from IE, Edge, and Chrome with no positive results.


Im having exatly the same problem. Cant accept the terms and conditions. I have tried on IE, Edge, Firefox, Chrome browesers, but with no success. I also tried on windows 10 and Android devices but also had no sucess. Its most likely a bug in the firmware as the cancel button works just fine, as do all the other buttons in the web app.

I note there has been no reply to any of the threads sharing the same problem. I am seriously disapointed in this as i would have expected better from WD.

Andy - I also am disappointed in the support from WD. I’ve had a case open for more than a month now with no good resolution. Through tier 2 the “solution” to try is a Factory Reset including a wipe of all data. This is not palatable to me. I’ve escalated to tier 3 now and their “solution” to the issue is to send me a new enclosure which I can set up and then spend all the time and effort to recreate my configuration (users and shares) and manually move all my data.

As a side note, I didn’t start to get decent responsiveness from tech support until I started commenting in Public spaces (Facebook and Twitter) about this issue and how poor tech support has been for me. I also sent messages to WD via Facebook and that seems to have triggered a different customer service group.

WD Support did send me a new enclosure to try to rectify my issue. I bought a new WD Red HDD to set up clean. Same problem. I just emailed them the results today. We will see what they say.

Here’s a link to a cross post on the issue.

OK. I have finally figured something out that has fixed this issue on my EX2 Ultra. It’s a weird solution and I don’t know where the true root cause is, but this is what I have to do when this happens to me.

  1. Hibernate (shut down my NAS)
  2. Physically change the Ethernet port the NAS is connected to my Broadband Internet provider’s router
  3. Reboot my Broadband Internet provider’s router
  4. Start my NAS

After that process, I am able to see the application list over the Internet AND I am able to accept the Licensing Terms and Conditions, necessary to manually install an application (like Plex).

My Internet provider uses a Technicolor DPC3848V DOCSIS 3.0 Gateway. It’s 4 port Ethernet and 1 WAN (cable - coax). I have 3 devices plugged in (including my NAS), so it’s fairly easy for me to swap the port. I tried playing with the UPnP setting and other port mapping features and none of that worked. Weird.

just hit tab untill the accept is highlighted…

Yeah. That didn’t work. It was a networking related issue as I’ve explained above.

Can you post the link that’s in the title bar?