How to unbrick a totally dead WD My Cloud

Hi all, a simple post to thank this community for helping me out on bringing back to life my wdmycloud 3tb.


I got it bricked while trying to install minidlna on v3 firmware and the system just stop working.

solution (maintaining the data !):

what I’ve been doing is to plug the hard drive to the sata port of a dekstop computer (seems possible to do it though the usb3 though… so no risk to break the case…need to be confirmed)

donwload the data contained in the dropbox folder :

and follow the instruction as it were a new hard drive, I simply didn’t format by data partition.

once all the dd were done, I re plugged the hard drive in and restarted it, and BOOM, blue light

hope it helps someone else.


You can’t do it via the USB port on the device. You need to connect it via the internal SATA connection. Bricked mine 3 times now lol.

The only way that I was able to unbrick my device was deleting all the partitions and dd the virgin disk file. This is what I did:

  1. Disassemble My Cloud.

  2. Use SATA to USB cable and plug into computer running linux.

  3. Mount device and recover data off partition.

  4. Delete all partitions using GUI application.

  5. sudo dd if=/path/to/virgin.img of=/dev/

  6. Unplug from computer running linux and reassemble My Cloud.

  7. Power up.

  8. Profit

I wonder how/if a docking station would work?  It provides the power and a USB connection.

No brick here, just wondering.

Fox_exe wrote:


Backup image

  1. If you use this instruction - no.
  2. No need to get full-size image. Just RootFS, kernel and config. (See header)
  3. See this:
  4. Yes. Sometime WD replace “dead” cloud to another or repair hem in few days.

man I LOVE YOU! last time i bricked my my cloud i fixed it just by restoring rootfs… now it didnt work… but your guide works just great… thank you for saving my drive and my files:)

I have restored my wdmc.

then i pluged it in the small plate and then boot up but i cant connect to the mc.

i connect to power and then first white led, then blue led first i can connect to the dashboard after a few minutes (2-3) there is no more connection to the dashboard.

in the first time i cant restore to factory defaults and can not update the firmware.

what can i do now?

Because in order to access the disk file system directly, without the mycloud’s operating system getting in the way, you need direct access to the SATA interface. It’s like asking why you can’t get direct access to the hard disk on a Windows PC…

Then, has anyone found a method that DOES NOT require “reformatting the ENTIRE disk”?

Have you read the entire thread? Most of the suggestions involve simply overwriting the OS partitions.

Is this proprietary? If so, then WD needs to change that because I AM NOT accepting that I just need to delete my data. That’s bullshit and scammy.

It’s a Linux ext4 filing system. The only proprietary bit is the design and use of the partition system to support limited RAID on critical partitions, and create the user space partition. There’s nothing ‘bullshit or scammy’ about that.

Provided you can get the mycloud working again, it doesn’t matter what happens to the data on it; to recover your data, just go to your backup device. You do have a backup for the mycloud, don’t you…?

Often when one bricks the My Cloud they cannot access the My Cloud via SSH. When this happens about the ONLY way to access the My Cloud hard drive is to open the My Cloud enclosure. At that point it is a trivial matter to remove the drive and connect it to either a SATA to USB adapter or direct to a desktop computer with a SATA port/cable.

If one can still access their My Cloud via SSH then it may be possible to fix certain issues and or push a firmware upgrade to the My Cloud. Do a forum search and you’ll find several threads on how to perform a firmware upgrade via SSH.

The My Cloud is a network attached storage (NAS) device, NOT an external USB hard drive. Like many low cost NAS devices where the NAS OS is on the hard drive, if the hard drive becomes inaccessible the NAS OS becomes inaccessible right along with it. At that point generally one has to pull the hard drive to gain access to it.

The OS on the My Cloud is a form of Linux. Generally the Windows OS cannot access a Linux formatted hard drive without some additional drivers. The easiest method is to use a Linux boot disc to boot the computer the My Cloud hard drive has been attached too.

Do a subforum search for “unbrick”. There are several methods that involve just pushing the “img” files to several of the My Cloud partitions and don’t involve destroying existing user data. But again, to do so generally requires one to remove the hard drive from the enclosure and connect it to a computer.

Unbricking a My Cloud IS NOT OFFICIALLY SUPPORTED by WD. If you unbrick you do so at your own risk !!! Generally the official method is to contact WD Support and RMA the My Cloud unit which may cost one money if not under warrantee.

Several of the unbrick procedures, like this one that I’ve used several times, indicate how to push the “img” files (kernel.img, config.img, rootfs.img) files to three of the partitions. One just has to obtain one of the backup archive type files from one of the unbricking threads (the link previously posted in this post includes one). You just need to ignore most of the preceding stuff about partitioning and formatting so long as all the partitions are intact. Note use the correct “sdx” entry for your setup.

sudo dd if=kernel.img of=/dev/sdb5
sudo dd if=kernel.img of=/dev/sdb6
sudo dd if=config.img of=/dev/sdb7
sudo dd if=config.img of=/dev/sdb8
sudo dd if=rootfs.img of=/dev/md0

Once the hard drive is attached to one’s computer one can, if the user data partition (generally partition 4) is intact, still access their data and copy that user data to another hard drive.

As some of the unbricking guides indicate use a Linux Boot Disc (also called a Live CD). One popular Linux distro is Ubuntu. One downloads and burns the ISO file to a DVD disc or to a USB flash drive, then one boots their PC with the DVD or USB flash drive. From there one can use GParted if needed or can use the command line terminal to issue the commands to push the IMG files to the various partitions.

More info about recovery (And other stuff): G.Drive or mirror

If you had clicked on the link I provided above to the direction I used you’d see the information on how to push the IMG files to the proper partitions when the RAID MD0 isn’t mounted…

sudo dd if=kernel.img of=/dev/sdb5
sudo dd if=kernel.img of=/dev/sdb6
sudo dd if=config.img of=/dev/sdb7
sudo dd if=config.img of=/dev/sdb8
sudo dd if=rootfs.img of=/dev/sdb1
sudo dd if=rootfs.img of=/dev/sdb2

The linux swap partition is disk space used by the operating system to swap out parts of program memory to make room for other programs. When the swapped out memory is required for the program to continue it is read back in from swap space and some other area of memory is written to swap space.


Can someone please post the instructions and the image links. The google drive link in the above messages don’t work anymore. Thanks a lot.
Please, dont share link to files, only to root folder (this link), because Google change link to file when it edited/replaced.

Could the “WD My Cloud 2TB virgin disk image” be used to unbrick the “Wd my cloud mirror gen 2” device?

No, for two reasons:

i) The image is very likely to be the older, Gen1/v4 firmware
ii) It’s for a MyCloud, not a MyCloud Mirror; different hardware (processor included, IIRC).

That was what I thought, is there an Image for WDMC Mirror gen 2? Or how can I unbrick such a device?

No idea. Try asking here:

Hey guys,

I tried to follow this instruction with the 2TB Image and a 4TB HDD, but unfortunately I had to skip #14 and 15 because I didn’t received an error. After typing in unit s + p, I only got an overview about 2 existing sectors (not 4 as it’s written here). Furthermore, the start sector of the last partition (which was 2 in my case) was 77056s.

I continued with step 16 (but didn’t got a warning again) and finished the instruction, but currently I only get a permanent white LED and can’t connect with the software.
Do you have an idea what I’m doing wrong or another solution?

Thanks and best regards!