How to test the access times, like read and write of the NAS drives, over the network

I am worried that the NAS is too slow. I am supposed to eventually replace the server with this NAS. But I noticed that the server was faster in an operation than the NAS.
The operation was to read and then write what is in a directory. The same operation was carried out on the server and on the NAS. Prior to carrying out the operation, the directory on the server was copied to the NAS. So I wanted to see that the contents in one are the same as the contents in the other. If they are, then I copied everything correctly. I observed the File Explorer, and also the Windows Powershell, to watch when the operation would finish. The operation took a minute on the server. But on the NAS, the same operation is still running. Both directories amount to 60 GBs of files each.

The operation is to read and save information about the directories, subdirectories, files, filesize, dates, etc to a log.txt file.

The operation I ran from the Powershell on both directories is “cmd /r dir /N /TC /Q /S /P > log.txt” both directories should have the same content because I ran a command to make a copy of what is on a server folder to a share folder on the NAS. Here’s the command I used:
where P is the source directory on the server and U is the destination share folder on the NAS
This command copies and makes sure that the copied files keep the date-time stamp of the original files, and makes sure that any files already on the NAS aren’t deleted, so I can run it again if anything new is in the source directory.

I am worried that the NAS system is much slower than a Windows Server system, in particular when doing operations like reading a directory of tens of gigabytes of files.
I ran the same operation on equivalent contents but one on the server and one on the NAS. The server did it in under a minute, but the NAS hasn’t finished and it’s already been two hours!

Hi @jairowd,

Have you opened a Support Case? If not opened, for more information, please contact the WD Technical Support team for the best assistance and troubleshooting:

If you have a Gigabit switch and the NAS is connected to it then on the NAS’s side fix the link speed to 1000 and don’t let it auto-negotiate. Is should not be a problem but I solved a speed problem between a DL4100 and a NetGear unmanaged gigabit switch. Auto-negotiation always selected 100Mbps. I fixed the speed to 1000Mbps on the NAS and then happy days. :slight_smile:

I also noticed that if OpLocks is turned off that transfer can be quite slow so make sure OpLocks are enabled.