How to substitute a jpg got as a thumbnail for a folder?

I manually inserted a JPG  file inside a folder. According to equipment guide, the image inside this JPG file would be used as the thumbnail of this folder. And i t worked like that. My problem started when I tryed to change this image. I deleted the JPG and introduced a new one in the folder. I must mention that it is the only JPG file inside this folder. But no matter what I do the equipment doesn’t substitute the initial image with the new one. I powered off the equipment (holding the on/off button for more than 4 seconds)  I cleared the library and the system recompilide it again. Nothing works. I tryed to find out if the original file is hidden inside the equipment but I can’t see it. Any thoughs?

Connect to the Hub via your PC.

Delete the hidden folder named “.wd_tv\thumb”

I tried but I received a message saying that it’s not possible to delete the file. I’m connected to the hub via the network. Should I connect my PC to the HUB directly using the USB port? 

Don’t map it as a drive, if you did disconnect it. Then go to it under Network as a media device. Once you delete the directory map the hub again.

I tried this procedure (unmaping the drive and also rebooting the PC) but I received the same message saying that I can’t delete the file.

Please post the EXACT error message you’re receiving.

Are you turning off the Hub before you try to delete? It may be that the folder isn’t being deleted because it’s in use by the Hub while you try to delete.  Just a hunch.  Try to turn off the Hub first (using remote power button, not a full power down, or it can’t be accessed by the network). 

In general here are procedures I’ll repost from a previous post of mine that work for replacing thumbnail jpgs. This procedure works well for me and some other people have confirmed it works for them too.

Here it is: 

Just thought I add my two cents since I have been changing thumbnails a lot.  I make them on the computer, and add them over the network share.  The only efficient and dependable way I have found to get the Hub to recognize the new thumbnails and “forget” the old ones is to do it like this:

After I’ve added the thumbnails (e.g. folder.jpg, or thumbnails named identically to videos) to the Hub using the computer, accessing the Hub as network share, then

  1. Turn off the WD using power off on the remote.

 (you don’t need to unplug or do a hard shut down, in fact this won’t work if you do because you need to access the WD as a network share)

  1. From the computer find “thumb” in directory from the .wd_tv directory in the root HUB directory. Then, delete the whole thumb directory, or navigate more surgically to find the directory you changed or even the actual thumb files. The WD regenerates them rapidly, so it’s not a hassle for me with several hundred thumbs to delete a whole directory. 

  2. Restart the WD using power on from the remote,

  3. Then immediately do a “device restart” from within the menu.  (Home --> Setup --> System --> Device Restart).  This is more like a reboot than just powering off/on with the remote. 

This seems like a lot but it’s been sure-fire for me after a lot of experimentation, with turning the unit on and off, rebuilding the library, moving directories around, looking for files in different views on the Hub, etc. It’s a lot easier than trying “easier” things over and over and/orwaiting for the HUB to get around to finding changes.

Careful though in deleting anything from the Hub, there’s no recycle or undelete function that I know of.