How to stream mycloud to Vizio smart tv?

I just bought a mycloud, so I can access my files from multiple devices and especially to stream to my new tv. Since both devices are new to me, probably puts me at more of a disadvantage. That said, I’m good at reading instructions and figuring things out. But I have not been able to find instructions for how to access my mycloud files from my vizio smart tv. I found a youtube video from wd that discusses that it can be done, and then only explains how to access them using the wd tv device and their smartphone remote. Do you use the smart phone remote when you have a straight smart tv and not the wd tv? I was thinking no. 

In my many google searches I’ve come across many people discussing streaming from the mycloud to a vizio smart tv, mostly problems with specific file formats, but can’t find any instructions on how to do it. 

First off your smart TV will need to have DLNA client support. In other words an app or option on the smartTV that will play content stored on your WD My Cloud in folders that have “Media Streaming” enabled. See  this Vizio link for general information on how to access a DLNA server from a properly supported or equipped Vizio TV.

Second, your media content stored on the WD My Cloud must be in folders that have Media Streaming enabled on the folder, and be in a format that can be accessed and streamed to DLNA clients like certain smartTV’s, PC’s, tablets and smartphones. If a DLNA client is not DLNA Certified then it may not support some media formats.

See  this WD Support link even though it doesn’t specificity list the WD My Cloud for the general file types supported by the Twonky DLNA Media Server that is embedded in the WD My Cloud.

If your media is not in a Twonky Media Server supported format then it will have to be converted to a supported format. There are various free and paid software programs that will convert audio, video and graphic files to the requested supported Twonky format.  Handbrake is one such free program for converting video files to MP4 or MKV formats for playback via DLNA server/clients.

If one’s smart TV doens’t support DLNA clients then there are stand along set top box type options such as; Chromecast, RokuAppleTV and other similar devices that have the capability of streaming content from WD My Cloud and similarly equipped network DLNA servers to the TV.

Good advice from Bennor.

This might help with the specifics of running Twonky on the MyCloud:

In particular, the section ‘How do I start the Twonky server?’

Thanks! I’ll start working on it. Right now my tv isn’t working though… I bought the thing almost 2 months ago and haven’t really been able to use it. First it was defective turning itself off, and a repair person came out and replaced the main board. then it wouldn’t connect to the internet, so they replaced the whole tv. Now this one has connection issues, but in a different way. The one before was bad all of the time, this one seems to get drastically different results within the span of minutes sometimes. Right now it won’t connect online at all. This time they say its between my router and the tv (they had me change the router to G, but that seemed to make things worse) and I have to wait for someone to come out. But sometimes its magically working perfectly, sometimes not at all. Today is one of those not at all times :frowning: So much for setting this up damnit. Originally I was having problems with netflix but NOT youtube, so I thought if I set this up maybe I could stream my own stuff even when netflix didn’t work. But apparently today its not connecting to the internet period. 

My movie files are all in the list of accepted formats, so thats good. I didn’t think that would be a problem. When I was googling it mostly seemed to be a mkv issue with certain tvs, and I dont really use mkv. 

I’m not a fan of ‘smart tv’: generally, they are a closed platform, with a very limited set of apps, which are rarely updated, and often have unfamiliar UIs.

I prefer a ‘dumb TV’ with HDMI, and use a cheap Android media box to give me the smart bit; standard platform, full range of frequently updated apps, and cheaper than an equivalent ‘smart TV’. I’m posting using this combo…

Yea I probably wont buy another vizio after this! I bought it as a refurb though, and now have a new tv because of it not working so thats pretty cool. And they do stand behind their products, giving me the full year warranty as if it WAS a new item. In fact I have no doubt they’ve spent more money working to get me a fully working tv than I spent on the thing to start with. Its a 40" and I spent 220, plus had a walmart gift card so only paid 150 cash. So not too bad. The issue now is between the tv and the router, so more of an internet service problem than a tv problem but they’re still sending a guy out to my house to work with the router and tv together and get it going. They said this isn’t unusual with Brighthouse cable service. But that kind of pissed me off, like I wouldn’t have bought it had there been a brighthouse warning. But then again they ARE standing behind their product until its fixed. Its just been so crazy frustrating waiting. 

I’ve hit my first snag though. The instructions here: say to use the playpoint app. I didn’t see it in my list of apps, and can’t seem to find it at the yahoo app store either… 

I’ve been wanting to set up a home network for years to view my movies and tv shows on multiple devices. I’ve had a 1TB external hard drive. I have an old desktop computer a friend sent me and I was going to set it up as a server in the back room, but then I got this deal on a new wd mycloud 3TB for only $90 and this way I can bypass setting up a server and messing with the desktop. So I’m really excited about setting this up! Especially with the tv. My last tv before this was made in the 90s. I have had roommates with nice tvs, 6 months with a guy who had like a 60" plasma before moving here. But I never make purchases like this (the computer stuff is always work related too so not just enjoyment) so I’m really anxious to get everything up and going. 

What model TV have you got? I notice that support page is from 2013, so may refer to an older model.

But if you only paid $220, you may have an old model. Very good price, though…

Looking at the latest model (E40-C2)'manual on their website, I’d suggest looking at the ‘Multimedia’ app. I note this app and the ‘settings’ app have little padlock symbols on their icons, which suggests they’re built-in apps that cannot be removed, and I’d expect a DLNA client to be built-in.

Shame they gave up on the manual when they got to apps, as the rest of it looks very detailed, including a detailed description of the USB media browser, which for a smart TV advertised as DLNA-compliant, seems to be missingvthe point a bit…

Ah, I have a new model. My refurb was at least 2014, and now I have a completely new tv. Its a E400i-B2. 

I did try the multimedia app the other day, but then again maybe it did nothing because the internet on the tv wasn’t working at the time. I sent a message to vizio asking for help about the playpoint app last night but haven’t heard back yet. And of course, now the internet isn’t working. So I’ll have to wait for it to be working again to try things… Thanks!

Ok, so yes multimedia it is. I click there and it pulls up the laptop I’m online with, and mycloud. However when I click mycloud I get the options of Music, Video, Photo. I click Video, and do not see any of my folders or files? On the left there is a frame that I can’t seem to do anything in. It says DLNA2: WDMyCloud and then shows a folder called root under that (which cannot be highlighted/selected). Below that (also not reachable) has 2 button looking things with Sort: Date New-Old, and View: Folders. On the right frame says WDMyCloud\Video\root and then what would be a list of files I believe but is empty.

When I use the mycloud app on my phone, the files appear. 

Okay, time to get Twonky working properly. Read the FAQ I posted earlier to find out where to put media, and how to get Twonky to serve it, and offer the views you want.

I have this exact same problem (X4), I bought all new Vizio Smart Tv’s a 60" and 3-36", they all have the same problem.

I use the multimedia access from the root Viaio app, it finds the cloud, Loads the Menu’s (some times it freezes and only shows a few fiolder and has to be reset, other times iot finds the folders and moves appear (sometimes partial list, sometimes a full l;ist). If I act quickly, I can access a movie and it will play (there is a problem with mp4.files, but the AVI files will play (sometiomes the entire movie, most of the time it locks uop 4-5 minutes into the movie or video.

I have spent hours trying top get it to work with the Vizio customer support, initially the DLNA question was addressed. According to Vizio, all of there smart Tv’s are DLNA compliant. I tried using the windows media server as a DLNA Media Server, connecting it to the WD MyCloud, this had limited success and the computer had to be on to access the Cloud.

I have a Fire TV pluged into the TV, and can access the Cloud through an app called Vimu, it works, but looses its connection when it is used a number of times, and the cloud has to be rebooted.

It would be nice to access the cloud on the other computers, they do not have a fire TV.

Any new idea’s ? ? ? ?

Bump… Ok so the internet is working on my tv, they replaced the main board again and got it working. Sometimes it loses the great photo or buffers, which they think is because I live in such an old house so I’m going to pick up a wifi extender. 

But I went to start setting up twonky, and I’m confused. Going through the FAQ, I got stuck on the static IP thing because I don’t know what to set for the netmask. The first two settings were already set on what was instructed. 

Do I understand it correctly that I can only stream to my tv files that are in the public folder? I don’t have anything in the public folder. The stuff directly on my mycloud is in a folder titled with my name. So I need to move it all to the public folder to stream to my tv? And I have a 1 TB external hard drive hooked up to my mycloud… How do I set up to stream stuff like that through twonky? 

 Do I understand it correctly that I can only stream to my tv files that are in the public folder? I don’t have anything in the public folder

No: whilst Twonky defaults to using the Public share, you can stream from Private shres, too. See the FAQ:

Q. Where should I put my media so Twonky finds it?

I don’t use a USB disk on my MyCloud, but I recall that it is given a share name in the MyCloud’s file system, so if you can find that, you should be able to instruct Twonky to look there too.

IP netmask? Depends on your router, and the range of IP addresses it makes available. If the DHCP-allocated IP address is 192.168.1.XXX, set the netmask to

Or use your router to set an infinite lease time on the DHCP address it has allocated your MyCloud; that’s what I do. It will say something like ‘always use this address’.

Lin171 wrote:


Do I understand it correctly that I can only stream to my tv files that are in the public folder? I don’t have anything in the public folder. The stuff directly on my mycloud is in a folder titled with my name. So I need to move it all to the public folder to stream to my tv? And I have a 1 TB external hard drive hooked up to my mycloud… How do I set up to stream stuff like that through twonky? 

You can stream media content (DLNA) from any Share folder, public or private, that has “Media Serving” turned on for that Share.

When you connect an external USB hard drive to the USB port of the WD My Cloud, the My Cloud should automatically enable “Public Access” and “Media Serving” on the external drive. At least it does for me. If you have a lot of media content on the external drive it may take the My Cloud some time to scan the external drive.

Ok I’m making progress but still having issues… 

I can now find the content from mycloud in my own folder as well as shared folder from my tv. But I still cannot find the content from my external hardrive thats attached. 

In the twonky dashboard I added the drive to sharing, selected all content types. In advanced I clicked on rescan content folders. Back in the wdmycloud dashboard, under Media it has no numbers, and under Last update it says “Updating Database” which has been going on for over an hour… 

Anyone? I forgot to mention it in the last post, but I tried turning off the media sharing and turning it back on and the same thing happened, it just stuck and never finished. I can still find the stuff on the mycloud under folders, but not the stuff on my hard drive (which is 1tb full of stuff vs like maybe 20G on the mycloud, so its really important to me to get this working!)

That is the reason I do not have a smart tv, as they are not that Smart yet. At least it is my personal opinion.

If you are a techie, could be fun to play and figure it out. For the rest, just headaches.

I have the Amazon Fire TV + Kodi to play the media from my NAS. Love it! Long gone are the days a full blown HTPC was needed.

Well even more problems now. I went to watch something for the first time… And it makes my tv freeze up. I selected which movie I wanted and nothing happened. After a while I tried to move around with the remote, nothing. Tried to hit back, exit, etc. nothing. Turned the tv off, that worked. But it wouldn’t turn back on, so I had to get up to reset it. Tried again, same thing. So I ALSO can’t actually play the files even though the tv is finally finding some of them… 

The Twonky UI has a media browser, in the top right corner of the page (‘video music photos settings’). Can you see media on the USB drive using thàt? If you can, then Twonky has scanned your disk and added the media to its database.

Did you set an access password on the Twonky UI? If you did, the MyCloud will not be able to interrogate it to get information to display, and will show ‘-’ for all media counts.

I also agree with Shabuboy; smart TVs are generally poor, and I’ve advised many times not to bother, but to have your smart function external to the TV.

Smart TVs are generally a closed platform, with a tiny range of apps that are rarely, if ever, updated, and a non-standard UI. There is also a disproportionate price premium over a ‘dumb’ TV, compared to the cost of something like a Chromecast, FireHD TV stick, or cheap, generic Android box. TV manufacturers finally seem to be wising up; I see latest Sony TVs include Android TV.

Only this evening, I had to send an email to Sony, asking exactly what the purpose of the network port was on the KDL 40R453C I recently received, and why, although it has connected okay to my router, and been given an IP address, it ‘cannot connect to the network’; there is no guidance on either matter in the pathetic excuse for a manual that is supplied with it, or that can be found online.