How to stop MioNet Service


#1

Hi,

i have tried to stop the mionet service via the web admin console, but it keeps restarting itself even though the option “Enable MioNet on Startup” is unchecked.

This is on the MBWE White Light with the latest firmware.  Can i hack the config files via SSH to permanently stop MioNet running?

Cheers


#2

took the plunge and started to hack :slight_smile:

so far have done the following:

removed S9M-mionet from /etc/init.d

renamed /usr/mionet/changeNotifySocket to changeNotifySocket.STOP

renamed /usr/mionet/bin/cvm to cvm.STOP

so far mionet no longer starts on boot, or once MBWE has been running for a few minutes and everything else seems to be running fine.

Sounds like a lot of hacking to stop a service that isn’t needed - hopefully WD will come up with a fix or an “official” method of stopping mionet for users who dont want it.


#3

After more web searching found this  -  http://mybookworld.wikidot.com/forum/t-203006/solved:mionet-restarts-itself

may help someone else


#4

Perhaps I missed someone asking this question, but why can’t WD just make it possible for users to legally (i.e., without hacking) disable Mionet, without having it automatically restart every N minutes.  Keep it in the advanced mode part of the admin, so users beware…

Thanks,

– Bob


#5

HBOBN wrote:

Perhaps I missed someone asking this question, but why can’t WD just make it possible for users to legally (i.e., without hacking) disable Mionet, without having it automatically restart every N minutes.  Keep it in the advanced mode part of the admin, so users beware…

 

Thanks,

 

– Bob

Hi Bob

I think the problem is that there is a bug in the firmware that prevents Mionet from switching off when you request it from the UI. Hopefully this will be fixed in the next firmware release (whenever that may be )

Tony


#6

Thanks for the reply, Tony.

– Bob