How to setup MyCloud 3T to internet

Can someone point me to instructions for connecting my MyCloud to the internet? The instructions that I could find were mostly related to first time setup. Right now the Internet Status on the Settings Page and the Cloud Access page say No Internet Access.


Check this out My Cloud │ How it Works.

This link will take you to the User Manual.

Posted by,
cat0w (USA)

Thanks for the reply. The Best Buy is initial setup, and the manual doesn’t seem to have anything about configuring for internet connection.

I’d really not like to have to reset the NAS in order to do this. I have a bunch of data moved to it and this is my second device of theirs (Sent me a new one when the other seemed to have failed) and I don’t want to have to move the data twice for the second time.

what are you trying to access it with?

If you  are using the DHCP defaults it should already have internet access, if using static be sure dns, gateway and subnet are all correct.

To be able to get to it you need to assign an email address for a user in the UI, WD will send an email to that address with instruction on setting up a wd account which is required. After the user creates their WD account they will need to go to the web site or install the WD My Cloup app on a mobile device to sign in and connect

This is my problem. It says I have no internet access. And the internet is working in my house.

what is saying “no internet access”?

is your My Cloud using DHCP? Or static IP?

is the My Cloud acessable for your LAN? In windows file explorer try \wdmycloud\public or \IPAddess\Public

can you get to the console UI with a web browser http:\wdmycloud\ui if not try IP address instead of wdmycloud

Hi, I understan what bdphifer means, I have exactly the same problem

The device is configured to use DHCP

I have complete access to wdmycloud internally or local, from my pc ( windows 7 )

I have complete access to internet from any pc in my local network

I try to access my wdmycloud from ( I logged in with my account and see the device listed ) and is not possible I have a message “The device is not connected, verify your internet connection, active the remote acces and try again”.

I am in the installation procces, this is the first time I try to access from internet

My router is using a dynamic IP, so I think my problem is with the router configuration and not with the wdmycloud,  I dont know how to configure it, before this moment, all my local devices can exit to internet but they cannot be reached from internet, maybe that is the cause…

I will appreciate any help to fix this issue


Another thing,  when I access the dashboar app I saw a warning message inviting me to update the firmware, I accept and now I have 5 hours waiting for the update process and it has done only the 36% ??? it is advancing to slowly

Is possibel to abort this update ?? 


Have you given all your devices remote access? The top image is found under Settings>General and is shown on page 76 of the User Manual.


How is your My Cloud connected? Is it connected to your router?

Posted by,
cat0w (USA)

My MC is set up for static IP, because that was suggested as a solution to the continuious dropping/reconnecting and sleeping issues that I was having with this device.

Is that possibly a cause to my problems?

I can’t check for updates or anything because it doesn’t believe that it is connected to the internet.

I cannot turn on cloud access, because I do not have that option. My Admin use on the Cloud Access screen looks like this…

The Connection Status is what I am talking about, and the “New Unregistered Device” is interesting, and I am unable to remove it. Whenever I try to adjust anything, I get errors.

The MC is connected into a GB switch that is connected to the router. everthing else that is connected to that switch operates correctly.

The settings that I have for the Static Network Mode are shown below. The IP address from the router, and the DNS Server 1 is the IP address of the router on the network.

I can’t see your images yet but take a look at this and see if it helps.

Posted by,
cat0w (USA)

have you tried to use dhcp in mycloud

and reserve a specific ip from your router?

log in to your router, search for dhcp server related stuff

you should be able to see all device connected to network and their ip 

make the ip reservation from there

reboot your device when done

not sure why your images in your last post are not showing although the older post is now showing them, they wern’t showing yesterday

I am not sure if you are windows or mac, these steps are for windows, can probably do somthing similer on mac but i can’t help there

in a command prompt type type ipconfig /all

you will see information for 1 or more ethernet adapters, if needed identify the one on the LAN with the mycloud

look for subnet mask, default gatway & DNS servers, be sure these are exact matches for the values in the mycloud settings.

make sure the ip addresses are really on the same network, for a subnet mask of the 1st 3 numbers need to match between the PC & mycloud. the address of the mycloud needs to be unique on the network and outside of the DHCP pool on the router.

if all this checks out see if you can temporarily disable the firewall on your router to see if it is the issue.

you could also try DHCP on the mycloud although some people have reported connections dropping with it. if DHCP works the issue is one of the items I listed above

Now that I can see your screens the gateway need to be set to, without a gateway set the MC can’t see past your LAN.

and the DNS depends if your router is providing DNS services, some do, not all. check what your PC is using for DNS and match that or sign into you router and see what it has for DNS and set it to that. even if your router provides DNS it will not hurt to use the address from your provider