How to retrieve data content when drive cannot be mounted

Hi there,

I have my LiveBookDuo 4TB for only around 2.5 years. After shutting down the device for two weeks without usage and booting up the device for the first time one of the drive cannot be mounted. I don’t have anymore access to the data content, very unfortunate I was using RAID0.

Any ideas on how I can try by my own to salvage the data before seeking professional help?

The LED on device is lighted up in RED.

I have tried to reboot & perform short test on utilities a few times but still the same results.

Anyway to resuscitate the drive?

Can anyone share how much it would cost to get professional help to retrieve the data for a 2TB drive?

Thank you for your support.

Regards,

Kim

 

My controller failed on a My Book World, and I downloaded  “raise data recovery for XFS” for 26EURO from http://www.ufsexplorer.com/

That allowed me to connect the drive to a sata port on my PC (or use a SATA hard drive dock) and browse the linux partition from in windows.

I believe they have a trial so you can try the software

Hi Caboo,

Thank you for your reply & assistance. I tried out this ufs explorer standard recovery and indeed you are right that I can see the folders inside the ufs explorer but it is not possible to extract the files.

You mentioned to use the Raise Data Recovery version but which version did you use? there are several options like for NTFS, FAT, FAT32, XFS, HFS+, Ext2, Ext3, Ext4 & etc. For our case, if using RAID0 or RAID1 which verision should be used?

Thank you once again for all your kind assistance.

Regards,

Kim

i think the version depends on the file system of the drive model you had.

mine was XFS so i purchased that version

Hi there, Thank you for your advise but when you tried the do the data recovery, what is the recover file system type you chose? Is it SGI XFS file system or No file system (pure IntelliRAW)? I am not sure if there are more file system type if i purchased a license version as i am using just the trial version. Apart from the above question, when you opened the Data Recovery for XFS app the drive which you tried to recover the data can you see all partitions or there were some unknown partition? For my case, I can see that the biggest partition which is unknown partition would be the partition that I want to recover. Thank you once again for all your help. Kind regards, Kim

I went here and did the quick download (its free):
http://www.ufsexplorer.com/rdr_xfs.php

I connected my messed up hard drive to my computer via a USB caddy and it showed several partitions on the left.

Even without a license you can right click on the partition and choose to browse and it should open.

Once you get to a partition where you can see the files you need then thats the partition you wanted.

The partition should have a name starting with something like XFS…thats the type of license you need to buy in order to be able to actually interact with the files (copy them to a new backup drive etc)

Raise has seperate licenses for each type of partition you may want to recover, so once you know what partition type you have just click the name of the partition on the table below and choose to purchase a license

http://www.ufsexplorer.com/rdr_ntfs.php

http://www.ufsexplorer.com/rdr_fat.php

http://www.ufsexplorer.com/rdr_xfs.php

http://www.ufsexplorer.com/rdr_hfsp.php

http://www.ufsexplorer.com/rdr_ext23.php

http://www.ufsexplorer.com/rdr_reiser.php

http://www.ufsexplorer.com/rdr_jfs.php

http://www.ufsexplorer.com/rdr_ufs.php

The problem is when i choose the partition which I know the files are residing but when browsing on that partition I don’t see any files or folders. Is it because the partition has unknown file system? can we proceed to perform data recovery using different file system type and scanning the partition? I know it will take a long time but if that is the only option then I have no choice but to wait.

By the way, for WD Live Duo 4TB running on RAID0 normally use what type of file system? I am trying XFS but from the listing of the partitions of the drive there are 4 partitions - 2 partitions are using Ext 2/3/4 and the other 2 partitions are unknown file system type. Should I change the file system type to Ext 2/3/4 and perform the scan to see if there are anything that can be recovered.

Thank you.

im afraid i dont know how to help on this one. my drives were in a raid mirror and i just hooked it up and could see a partition with xfs format and it opened fine.

If both of your drives dont have a large partition with known type then i would suggest contacting WD Support and asking their advice.

May be something like having to have both those drives connected to the PC at once, and booting to a linux live CD in order to access the data.

If you have RAID 0 or JBOD try to use “UFS Explorer RAID recovery”: http://www.ufsexplorer.com/download_stdrr.php