How to Replace Failed HD in Mac Formatted G-RAID with Thunderbolt 3 Drive?


#1

I have a 16TB G-RAID with Thunderbolt 3.

When I got the unit, I formatted it for RAID 1 with OX X Disk Utility (OS X 10.11.6).
After about 6 months, one of the hard drives failed. After much back and forth, HGST replaced it.
I just got the replacement drive back, but can find NO instructions on the G-Tech web site on how to do it!

Do I manually reformat the new drive under Mac OS X Disk Utility?
Do I run the G-RAID with Thunderbolt Configurator?
Does the unit itself do everything automatically?

Should I backup the drive that hasn’t failed prior to installing the replacement drive? (probably a good idea)

PLEASE HELP!

THANKS!


#2

You need to use the configurator that you used to convert it to RAID1. Once that is open you select the device with the ‘D’ in the name. This is for Degraded. Once that is selected you click rebuild and it will go thru the process of rebuilding the device back to RAID1 protected.


#3

Lydia,

I didn’t use the Thunderbolt Configurator, I used Apple’s Disk Utility to setup RAID 1.
Does that mean I’m going to have to reformat and start from scratch?

BTW, You really need to include SOME type of instructions with these things.
The Quick Setup PDF details nothing more than where the cables go.
I didn’t discover the Configurator until later when I searched the G-Tech website.


#4

The G-RAID w/ Thunderbolt 3 is a hardware RAID solution device. You can’t even make a software RAID out of it unless you first use the configurator of ours to make it JBOD and then go into Disk Utility to make it. Which would very pointless. I don’t know how you created a RAID in Disk Utility without using our Configurator. A hardware RAID which our TB3 devices are is superior to a software RAID.


#5

I have the exact same issue as “copperhead”
my G-Raid 4TB is not regnognized by my Mac
only appear sometime in Disk Utility with a drive said “damaged”
That drive is nt under warranty anymore
I have a new replacement drive in hand, exactly the same
I ran your “G-Raid with Thunderbolt Configurator” app but “No Device Found”
what is your suggestion from there ?


#6

dforg, your issue is also the same as my last reply. The product you have is a software RAID older device that does NOT use our configurator app.

You would need to delete your software RAID within Disk Utility and create a new one once you have 2 identical working drives in the enclosure.


#7

Thank you for your fast rely to me Rydia
ok that is making sense now.
still not been able to see the drive in Disk Utility
will show only sometimes after “playing” several time w/ connector and power
if I “break” the mirroring RAID1, I will loose the data ?


#8

If you delete the RAID then yes it will erase the data. If the mirror was in place then the drive should still be mounted and you can transfer it elsewhere. Otherwise if you have a replacement drive in place you can select the rebuild option within the configurator if its our removable drive. If it is the older software based RAID there is an option to rebuild within the RAID assistant in Disk Utility as well.


#9

last night when I was able to see the drive in disk utility, I select “repair” on my G-RAID Master set, but the selection was “gray out”
at some point I was able the see the “good” drive and read the content
was very slow
I tried to copy the content on my 2sd G-RAID without success, the defective G-RAID disappear from DU


#10

That is SoftRAID and not associated with our drives at all it is completely 3rd party and we cannot support it.