How to recover my cloud home old files

Hi ,

I have my cloud home set up from old dash board. It established the link name as //MYCLOUD-RAK08E. Last week, I couldn’t access //MYCLOUD-RAK08E after windows 10 update. I tried to set up windows credential and to see if I can regain the access. Unfortunately, I don’t know the password. I tried other 10 methods published in the internet. None of them could make me to access //MYCLOUD-RAK08E. I finally went to new dash board to reconnect my cloud home. It setup a new link name. I can access my cloud home via this new link name. However, I cannot see my old files. I read posted messages indicating that I might have created a new partition when the dashboard created the new link name. Here are my questions.

  1. Is it true that my cloud home was created a new partition from dashboard with new link name?
  2. How do I access my old files from the old partition if the answer for the 1st question is yes?
  3. Or, the dashboard just created a new user name. The reason I couldn’t see the old files is due to users share issue.
  4. If it is new user name and share issue, how to make the old files can be accessed from the new user name without knowing the old password?

Your information are greatly appreciated and thank you in advance…

Best Regards,
Lon Chu

There is no dashboard in My Cloud Home but there is the WD Discovery which is needed to see the private space KDDFS. If you don’t know the differences, you should read the set up links and the manuals.
https://support-en.wd.com/app/answers/detail/a_id/7758/kw/difference%20my%20cloud%20home/related/1

@lonchu

Try the correct way, \\MYCLOUD-RAK08E

As already mentioned, My Cloud Home does not have a Dashboard. What device do you own? Is it a WDMYCLOUD?

WDMyCloudImage

My device is MY CLOUD HOME. Attached are the screenshot of the “My BOOK HOME” dashboard(?) that I was refer to. I may be wrong about the name of this utility. This is the tool I used to create new link to my cloud home. As you can see from the setup, I named this device as MYCLOUD-RAK08E to match with previous name. Unfortunately, I couldn’t see the old data under the new link. The file explores show two entries for the MYCLOUD-RAK08E. One mapped to the Y drive. The other one is under the Network. I clicked on this link. It pops up the error message screen. This is where I need help.

@lonchu

If you have a My Book then you should post your question in one of these sub-forums.
Latest WD Legacy Products topics - WD Community

WD Products, Hard Drives, USB Drives, and Memory Cards | Western Digital

edited: That PDF was hard to read with the 3 screenshots in the last page.
You have two other WD My Book Live which means you know what network problems you can have and you should contact tech support directly for the network problem which you should have shown in the first place.
https://support-en.wd.com/app/ask