How to recover deleted firmware? Solid yellow LED light


I have a 2TB wd my Cloud. I wanted to update the firmware but it kept saying Device does not have enough space for upgrade.

I installed winSCP and tried to remove some files from root/usr/lib

Now the LED light is solid yellow and I don’t have access to dashboard or my files.

I can not even connect with winSCP anymore.

I also tried to hold reset button for 40 seconds but nothing happened

Please help. thanks a lot.

Why did you remove files from the root/usr/lib folder using WinSCP?

A forum search turns up prior threads where updating the firmware via SSH is explained. Note most the directions are for v4.x firmware version My Clouds. The newer v2.x firmware My Cloud’s may use different commands to update the firmware via SSH.

#cd /shares/Public
#wget wget
#rm -f
#/usr/local/sbin/ /shares/Public/sq-040103-421-20150217.deb

Make sure to use the latest firmware name file.

One can find the links to the firmware in the following thread:

1 Like

Thank you very much Bennor,

Now the real problem is I don’t have access to my cloud at all, not via dashboard and windows explorer nor SSH !

I think the only way now is to remove the hard disk and attach it to a pc directly and then deal with the missing files

Any idea how I can access to my files?

One can access the data files on the My Cloud hard drive by removing the hard drive from the My Cloud enclosure and attaching it to a Linux PC, or a PC that was booted with a Linux Live/Boot CD. Windows generally does not have the proper drivers to read and access Linux formatted hard drives like the My Cloud is partitioned and formatted. There are third party programs one can install to Windows that would allow the reading of Linux format drives.

There are several methods for unbricking a hard drive, do a forum search to find them. Some of those unbricking procedures may allow one to keep their user data on the drive while performing the unbricking procedure.


I finally could access to the root folder with this software: DiskInternals Linux Reader,

But there is no option to add any file to root folder

And also I don’t know how to extract firmware.deb and select those missing files from it.

Thank you again.

Of course there isn’t. The Disk Internals Linux Reader program is just that, a READER. You cannot write to the Linux drive. From the Disk Internals website; “Secondly, the program provides for read-only access and does not allow you to make records in file system partitions.”

It is best to use a Linux PC or Linux Live/Boot Disc which will provide full read/write access to the drive and the files on it.

Ubuntu Live CD is one such popular Linux boot disc:

1 Like

I’m on ubuntu right now, here it is my cloud hdd and the /sdb2 is the location of firmware

and this is my usb flash drive that the mycloud2tb.img and latest firmware.deb is inside it

now I really don’t know what else to do, which file should be extracted to where and how?

What are you attempting to do? Extract the firmware and attempt to copy it to your My Cloud assuming that it will then boot?

Before going any farther you should read through one or more of the “unbricking” threads since that is essentially what you are attempting to do. Most unbricking process however will destroy any user data so one had to copy that data off the drive before proceeding to unbrick.

Note that attempting to unbrick or push firmware to the My Cloud through SSH or a Linux computer is not supported by WD.

One can “extract” the contents of the sq-040403-113-20160510.deb file, using an extractor program like 7Zip or similar. On Winodws extracting the DEB file creates (at least for me) a TAR file which can be further extracted. On Linux one may be able to right click on the DEB file and select “Extract to here” at which point the Linux OS will attempt to extract the files to the location where the DEB file currently residing. One may need to ensure if they have the DEB file on a flash drive that the flash drive is large enough to contain the extracted files.

I don’t know off hand if you can simply take the rootfs.img that can be eventually extracted from the sq-040403-113-20160510.deb file and push that (using DD on Linux for example) to the two “linux-raid” partitions like one normally does during the unbricking process. If Linux has mounted the RAID partitions on the My Cloud drive one may have to unmount that RAID partition prior to attempting to push the rootfs.img file to the RAID partitions.

You may be better off copying off your data (SDB4 in your screen capture) and simply unbrick the drive.

1 Like

Yes I found rootfs.img and put it on desktop, and want to move it to the root. But don’t know how !

Its like you are talking in chinese :sob:

please tell me step by step what to do and please talk as simple as you can

If you need step by step directions then go the full unbrick route and copy your data off the user (ext4) partition first. Here is one such unbricking thread there are others:

You might not be able to simply push the rootfs.img file extracted from the latest firmware to the RAID partitions using the Linux command prompt command: sudo dd if=rootfs.img of=/dev/md0 or if the RAID is unmounted using the commands:
sudo dd if=rootfs.img of=/dev/sdb1
sudo dd if=rootfs.img of=/dev/sdb2

I posted a thread on the unbricking procedure I used (primarily to get around the no dashboard issue when upgrading from the v3.x firmware to the latest v4.x firmware). In the following post has the basic directions I’ve used several times now.

Later in that thread user Fox_exe posted a link to a method of possibly unbricking the My Cloud without removing the hard drive provided one can still access the My Cloud via TFTP. I haven’t tried it so no idea if or how it works.

If you don’t know how to issue Linux command line commands then do an internet search to learn how to open the Linux terminal window and how to issue commands in it.

1 Like

when I entered this command: sudo dd if=rootfs.img of=/dev/sdb1

After opening the terminal window in Linux you have to navigate to the same directory as the rootfs.img file then issue the sudo dd if=rootfs.img of=/dev/sdb1 and sudo dd if=rootfs.img of=/dev/sdb2 command. Since you extracted the rootfs.img to the desktop you have to navigate to the desktop in the terminal window first (something like cd Desktop or cd /home/ubuntu/Desktop).

Make sure to change the “sdb1” and sdb2" to match your My Cloud drive partition entry setting(s) if they are different.

1 Like

I used Disks application restored the Virgin file.img (mycloud2tb.img) on another hard drive.

It created the whole partitions like the original one, with exact names and exact sizes. Then I used the Disks to “Create Partition Image” from those two “Raid Linux” drives and then restored them on the “sdb1” and “sdb2”.

And also extracted the latest version of rootfs.img whith your command syntax.

I even extracted an older version of firmware

But nothing happened at all :disappointed:

The LED light is solid yellow and blinks once every 90 seconds.

I really don’t know what else to do :cry: Sorry for my bad english.

I just noticed something new,

the network connection could not established and keeps disconnecting every 30 seconds.

I tested it with two different PC’s.

It keeps changing between these two situations over and over:

Its ‘bootloop’. Kernel partition damaged. Or, maybe, problems with HDD (Check SMART info!).
Open device, reupload firmware to HDD (Use my instructions:

1 Like

Well my system is back, I used @Fox_exe link and downloaded the v04 firmware

I restored bootfs.img & kernel.img & config.img with Ubuntu’s application DISKS

I did not use any command and terminal. Just Disks.

Now Dashboard works fine, and the firmware version is: v04.01.02-417

But there is still two problems, first I still can not update the firmware.

Check for Update says: No Internet access. Check your network and try again. (220004)

And the Update from File says: Device does not have enough space for upgrade.

The second and bigger problem is I can not take ownership or change the permission of any file. And when I want to delete something, the file will be deleted permanently instead of going to Recycle Bin. Is there any way to fix this? should I format the main storage drive?

I want to thank you all, I don’t know where you are from, but I’m certainly sure you are very very good people, special you @Bennor, you are a true angel. Thank you very much for every thing.

This is the Properties of my My Cloud:

It is possible that by using the Disks program you may have missed some element or setting that is configured or set using the terminal window which the directions you linked to use.

It is almost always recommended to perform a System Only Factory Restore via the Dashboard > Settings > Utilities > System Factory Restore > System Only immediately after performing the unbrick procedure BEFORE attempting to do anything else with the My Cloud. Typically a System Only Factory Restore fixes the zero free space issue and corrects the incorrect total storage size value that sometimes occurs after unbricking.

If one cannot read Russian there are similar English directions at this this link:


Well thank you again. after System Factory Restore I finally managed to update the firmware to the last version.

But problem with permission and files not going to Recycle Bin is still persist.

When the hdd was attached to pc, the files were deleted immediately via Ubuntu too.

In fact this was the main reason I manipulate My Cloud at the first place.

I mean this problem was exist before I even do something. and this is not anything to do with the Disks or what I’ve done to My Cloud.