How to recover deleted files

Hi Zhora,
You are most welcome. I like to help.
Did you go over the file type settings ? You can determines which file types you want to recover.
Additionally the file EXTENTION might have been changed, ie “.avi”, “.mkv” etc. You should be able to change those back by renaming them.

You can recover deleted files from WD hard disk with data recovery software, you may see this step by step WD data recovery guide.

Hello
sorry for my English
I fail to install apt-get install testdisk
-sh: apt-get: not found
I am well connected in root on the device
thank you in advance for your assistance

If you are running v4 firmware on the MyCloud , do not try to use apt-get to install from standard Debian repositories. The MyCloud uses a nonstandard 64k page size, so standard 4k page size images will, not work, and are likely to break the MyCloud.

I have 4 HDD montee JBOD on volume 3 unfortunately I delete a folder with lots of data sharing that I love recover .
I think that with testdisk photorec and I have had a chance to regain my files .
Content Updates my version is 2.10.310 .
thank you in advance

Content Updates my version is 2.10.310

That sounds like the firmware version of a MyCloud EX device. This is the forum for the simple MyCloud; they’re quite different devices, and have their own forums. You may be better off asking your questions there:

https://community.wd.com/c/network-attached-storage

Oh yes: as with all deleted data problems, you should stop using the device as much as possible, otherwise you risk overwriting the deleted data.

tank you :wink:

Hi,

I have tried to follow the steps to recover my deleted folder but I faced a problem :'(
    when I run "photorec" I got this error message:
              -bash: photorec: command not found
    when I run "photorec_static" I got this error message:
              -bash: photorec_static: command not found
    when I run "sh photorec_static" I got this error message:
              photorec_static: photorec_static: cannot execute binary file

     what is the way to run "photorec"?

Thank you for your help …

Where are you trying to run photorec?
Where have you installed it? If on the MyCloud , where did you get the image from?
Since you’re obviously running under bash, you must be on a Linux device.

‘Command not found’ most likely means you’ve not added the photo rec install location to your path. You can get around that by going to the install director and entering

./photorec

Or typing the full pathname of photo rec.

Hello,

I followed the following steps but I didn’t succeed to recover my videos :frowning:

What is wrong?

Well, for a start, you’ve installed an image built for an x86_64 family processor. This is a ‘PC architecture processor’.

The MyCloud is based on the ARM architecture, specifically the ARM_v71 architecture. So the image you have is not compatible with the MyCloud.

Thank you for your answer :slight_smile: I tried another archive. I succeeded to launch photorec but I got a “Killed” message

What is wrong?

It’s still obviously not compatible with the MyCloud. ‘Killed’ is a linux kernel message that generally means ‘I have no clue what this image is trying to do’

Unless you can get a version of PhotoRec actually built for the MyCloud , I’m afraid you may be better off removing the HDD from the MyCloud , and mounting it on a Linux PC, and running recovery tools that way. There are a number of bootable Linux images intended for system recovery.

OK. So the problem is: Where can I find a version of TestDisk/Photorec that can be used in “MCloud” !!

It seems that some people succeeded to use TestDisk/Photorec. Please, tell me where you found it… :slight_smile:

Thank you in advance for your help.

Did you see post #8 above that details how to do an: apt-get install testdisk

https://community.wd.com/t/how-to-recover-deleted-files/92885/8

It appears once Testdisk has been installed via apt-get from the SSH command line one runs photorec.

Is testdisk built for OS 3?

RAC

Had to create an account just to share this.
I accidentally deleted a share from the web UI and panicked.
Taught me that I need to get a RAID or implement a backing up system!

I tried all those disk recovery programs and it couldnt detect network drives.
I went half way and SSH into the MyCloud. Realise I couldnt fix it as the description above…

HOWEVER, I went into the root directory and found a Share folder in UNIX/SSH and saw my share folder still there however not showing up on the WEB UI?
All files still there…so I created a new Share using the WEB interface and copied the files into the new share and I can see my files again!.

Hope this helps. My first ever post on the internet to help

3 Likes

Hi Andy,

Is there any chance you could let me know the step by step way in how you managed to recover your share? I have today attempted to change a share of mine from private to public and it has deleted the share!!

I have been able to access the drive through SSH but not sure what to do next.
Any assistance would be greatly received, thanks!

Sorry to be annoying. I get stuck at step 4. I am logged into mycloud using putty but when i type “apt-get install teskdisk”, i get a message that it cannot be installed. I can’t seem to find or install the program.

What firmware are you running, on what device?

This is an old thread, dating back to v3 firmware, when it was possible to use apt-get to install standard Linux packages from standard repositories.

With more recent v4 firmware, that is not possible, and attempting to do so may brick your device.

With the most recent v2 firmware, running on gen2 machines, I don’t think apt works either.

I’d search the forum for threads about installing packages on v4 and v2 firmware.

It’s also a good idea to read the entire thread.