How to recover data from a failed My Book World edition?


#1

Hi all,

I have a 1TB My Book World edition (white)…
Been sat stationary/untouched since i bought it 10 months ago…
Logged in yesterday, just to reboot it (always figure its healthy to reboot devices/servers every few months)

:frowning:
Bad move, when i logged back into the web interface, it says ‘drive not reconised’, and failed to mount drive.  :frowning:

Updated firmware on unit, still the same…  (drive doesnt tick either, so HDD hasnt failed)

So, have taken HDD out the enclosure, and plugged it into my PC (Windows7)

Windows can see 5 partitions on the drive, as not NTFS/FAT32, i know it will format and lose the data the moment i try and add the drive…

Any ideas on what software i can use to extract my data off the drive ???


Rescuing data from an old WD My Book World Edition 1.5TB
Need help getting a My Book World Edition (Ethernet) drive to work in a USB enclosure
#2

nobody knows how to extract the data off a drive ???


#3

You could try:

http://partedmagic.com/doku.php?id=start

Since it’s linux-based you’ll need to mount it in Linux. If it has more than one drive be sure they’re both connected to the computer, and boot from a CD. 


#4

Cheers for the reply,

doesn’t help though…

I can boot up using the suggested software, but it will only see 3 partitions on the 1TB drive… (ext partitions)
A tool which i know of already is included in that PartedMagic, called “Test Disk”.

If i run that, it see the HDD size as 147gb ???
Yet run the disc tool/SMART, and it will see it is a 1TB drive…

I have around 300GB of data on that drive, and i would say 70GB is very important to me…

Just so i can understand this a bit more, the  ‘My Book World Edition’ with a single 1TB drive, is made up of:

5 partitions ??? or 4 ???
Is that 3 in EXT format, and 1 in XFS (for data) ???


#5

** UPdate**

I used some software called UFS Explorer to read the drive…
(seeing as the data partition is in XFS format, and not ext2/3 )

Anyway, data recovery =  NOTHING…  finds the folders and some of the files, but there all over the place…

So either the software is useless, or the XFS format is useless, or the build quality of the My Book World edition is useless ???

If i plug the drive back into the WD enclosure, is there an option in the web interface to restore the disc ? or try and rebuild the data area ?
Am guessing i will have to face facts and realise my data is gone, along with the reputation i once though WD had…
But lets say i had nothing to lose, and this happened, say 1 month after warranty…
Does that mean the whole unit is dead, or is there a recovery option, given the drive still works as the web interface can still be acccess… ?>>???


#6

Used some software called “Geeksnerds XFS Recovery”

Now this finds and shows the structure as i used to see it in Windows… and appears all my data is there in the folders as they were…

Problem is, the software costs £129 for the license, so i can recover my files.

The software to try as advised in post 3 doesnt show the XFS partition of where my data is ?
So, given WD make the drive, and the interface, and use that partition format, then a bit more help would be appreciated in recovering my data please…

In essence, the physical drive is OK, and would appear the partitions are intact (although i’m no linux expert!)
The fault is most likely with NAS board itself, or cant read the data partition, etc etc…


#7

Recently had a four year old Mybook World edition fitted with a 1Tb drive that had been working non stop until it keeled over with the same fault, data was intact but the control logic had died.  The on board interface for some reason kept reporting that “Drive A Has Failed” but was able to access it’s Linux based operating system on a separate drive partition.  A strange fault this, almost as if the Mybook was selectivly blind to what it was connected to.

There is a way to recover the data with little expenditure, I managed to recover all my stuff (some 400Gb) but you need a PC that is SATA based in order to be able to plug in the HDD and access the stored contents.

1)  Download from the internet a copy of Puppy Linux and burn it onto a CD as a bootable operating system.

2)  Remove the HDD from the defective Mybook.

3)  Fit the HDD to the SATA based PC, both power and data leads.

4)  Insert the Puppy Linux bootable distro into the PC’s CD drive.

5)  Instruct the PC to boot from the CD, you may need to edit your BIOS settings for this.

6)  Allow Puppy Linux to boot up from the CD and mount the HDDs in your computer and the Mybook HDD

7)  In Puppy, open the Mybook HDD into a Window, look for a suitable destination HDD on the PC and open that in a seperate window.  Note that if the drive is really shagged, this is final confirmation that you will not be able to view the contents and need to break out the kleenex.

8)  Drag and drop copy (hold CTRL) the files you want to save from the Mybook HDD to the destination HDD.  Note that some filenames may be unusual in length and may have to be renamed during this process.

9)  Once complete, shut down Puppy, turn off the PC, remove the Mybook HDD.

10)  Restart your PC, and back up your recovered files to a new source.

P.


#8

Will give the software a try now…

The Gparted software on the linux style boot wont reconise the data area as an XFS partition…

Part of me thinks to try formatting to XFS format, then trying to use the XFS data recovery tool, but not sure if thats a real bad idea ?!!!


#9

ermm…

tried that puppy linux, but that wont work…  it would work if it could read the XFS partition, but thats the reason for my post, is because the XFS partition is a bit nailed…  puppy is for just reading normal drives, that do work :slight_smile:


#10

*** PROBLEM SOLVED ***

Purchased ‘Raise Data Recovery for XFS’ for £20…

So far, it appears to be copying the data from that partition…

Shame i had to buy software to fix a fault that WD wont fix… 

Already dont trust Buffalo/seagate products, now lost faith in WD…

Hitachi from now on i guess!


#11

This worked like a charm!

My WD10000H1NC had been showing signs of problems, like audio files that I had recorded to it were showing up as bad occasionally, or even a few of my picture files.  I assumed the issue was just a few bad sectors on the drive so I didn’t worry about it and decided to rip a bunch of my old CDs to the drive.  Mostly everything was fine, still an occasional bad file or two, until I tried to SYNC my nearly 9000 songs in iTunes to my iPod Classic.  In the middle of the SYNC my WD10000H1NC stopped working.  The bottom light was on solid, but I could not detect the drive on my network anymore.  I tried resetting it, unplugging it, connecting it directly to my computer - nothing worked.  Finally I found this post with the instructions on how to connect the drive directly as a SATA drive and using Linux to mount the dirve.  It worked perfectly.  I had nearly 100 bad files but the bulk of my files were saved!  Thank you so much for you post, I really appreciate it!

Just FYI, when I booted up in Linux, my drived showed as 2 ext3 volumes and 1 xfs volume.  The xfs volume was the one with all my data.

Again, thanks for the helpful information!

Paul


#12

Hello,

I have the same issue and I still didn’t manage to recover the data from the WD drive.

I took it out of the MyBook enclosure and connected to a SATA connector in a desktop. Windows XP can’t see it with Explorer - I do see it through Administrative tools/Computer Management/Disk Management but it’s reported as being “Unallocated”.

I downloaded Raise Data Recovery for XFS and tried it in Demo version - I wanted to check that it does see the disk before purchasing it. It does see the disk (Drive1: Fixed WDC WD20 …) but it reports an "Unknown partition (sector0…)

so what should I do? I tried both “click right” on the disk and started “Find lost partition” but didn’t get any success. Same for file recovery… if it doesn’t see the partition I guess it is normal it will not find any file…

Some posts mention Linux as being the way to go but there is no clear explanations on what should be done - last post on Linux mentions that this will not work for XFS which is contradictory to Mr. Paul’s post whicn mentions “Linux to mount the drive”. 

Please explain what should I do in order to make the partition visible!

Thank you!


#13

I have used a copy of Acronis backup and restore to try to access a drive from a WD MyBook World 1 (Blue lights) and found that Acronis could read the data partition and display the folders. I didn’t try to see if it could access and copy the files to a different format because I had already managed to recover the data by another means, but I strongly suspect that Acronis will copy the files and will allow you to restore them to a Windows drive, since it can obviously read Linux partitions. Of course Acronis isn’t free, but considering it’s such a powerful and useful backup and restore solution, it may be worth your while to purchase a copy. Even if it doesn’t solve your problem (although I suspect it will), you still won’t have wasted your money. Considering that it would be convenient for me to have a Windows-compatible backup of the drive contents, I’ll probably try Acronis on my drive later. I’ll post another reply here to let you know the results.