How to prevent Dropbox files from being sync'd to both WD My Cloud device an laptop drive?

Help! Just purchased a WD My Cloud storage drive and want to use it as the destination folder for Dropbox. I was successful in linking Dropbox to the My Cloud device. However, the Dropbox files (almost 400Gb) were also copied to the hard drive of my MacBook laptop. And of course my Macbook hard drive filled up and quickly ran out of space. So, the question… How do I set-up the My Cloud device so that the Dropbox files are copied only to the My Cloud and no files are copied to the Macbook drive?? I was previously using a My Passport device for dropbox and it worked well and did not copy files to the laptop drive.

What does this mean? What software are you using? What or which My Cloud model did you buy? Did you install any other WD software?

Officially there is no direct linkage between the single bay My Cloud and Dropbox without using a computer.

Unofficially there may be a way using Goodsync to link the My Cloud to Dropbox without going through a computer.

I purchased a WD My Cloud Personal Cloud Storage device, there is no model number on it. I connected it to my router and followed the setup procedure on which downloaded the latest version. I then installed Dropbox and choose the My Cloud device as the destination / content folder. Everything seemed to be working well, all my Dropbox files were being downloaded to the My Cloud. But I soon got a message on my laptop the the local drive was running out of space. I learned that the Dropbox files were going to both the My Cloud and to the local drive. I do not want the files on the local as there a way too many Dropbox files. I only want them dent to the My Cloud device.

Are you using WD Sync too on your PC? Did you “map” the My Cloud to the local PC and then tell the Dropbox software to use that “mapped” Share as the location to save the Dropbox files?

Sounds like a possible configuration problem with the Dropbox software if it is saving files to your local computer in addition to saving them to the My Cloud. Check the Dropbox software to see if there is an option to disable saving to the local PC.

For members to help it would be nice if you know which WD My Cloud you own.