How to play 1080p videos smoothly at 24ps?


#1

Seems that any 1080p videos I play don’t play fluid smooth and there is a tiny frame pause about every second or so.  Is it because the live isnt switching my TV to 24 fps?  When I play a 24 fps Blu Ray, my TV switches to 1080p 24 mode, but the WD TV live doesnt seem to change anything?   I guess that the TV is in 60 fps or 50 fps and the noticeable frame stickiness I see periodically is because of this difference with the 24 fps footage?   As I can only play back 1080p at 24 fps on the WD TV live (someone tell me if this isnt the case) then how to achieve smooth playback?  I dont think I can manually switch my Panasonic plasma TV to 24 fps?

Would appreciate your thoughts on this.

Simon


#2

No, I don’t think that’s it.

What container are you using?  And how are those videos encoded?  And how are you playing them (local drive, streaming wireless or directly connected?)?


#3

I’ve noticed the same thing in 1080p MKVs. I have a Samsung plasma 50" and usually I notice a “stutter” or “lag” when the camera is turning around the room, all of the content just lags back a bit and it looks very weird and annoying.

I don’t know the cause, though.

It’s not my TV, because it’s only like 3 or 4 weeks old, and also I can watch other HD content from my DVR without any weird framerate or stutter or lag. Something about the WDTV makes it lag a bit, most of the time unnoticeable, but sometimes it can really annoy you.

Do you think changing the refresh rate from 60 Hz to 50 Hz will do any good?


#4

I am rendering to H264 1920x1080p 24fps mov with fixed bit rate at 8000 kb/s.  I assume the Live can only play 1080p with MOV files at 24fps?  Is there any other container I could try to render out to for 1080p?   I notice it especially on smooth slideshow transitions, as if there is a few frame pausing every second or so for just a few ms, but its noticeable. I tried today switching the output of the WDTV live to 24 and 23.9fps but that didnt help and it looked even worse!  

Has anyone successfully rendered out their own video files from say FInal Cut at 1080p for the WD TV live and if so, what settings did you use to getsmooth fluid motion.  I’m not too worried about panning stuff, but even static shots with subjects moving in can have this noticeable stickiness every so many frames.

Thanks for your help in advance,

Simon


#5

The frame pausing thing *sounds* like perhaps a drop frame issue with NTSC timecode, but that wouldn’t have anything to do with the Live per se.

I play strictly MKV files, and run my stuff through Handbrake (even stuff I’ve produced out through Adobe Premiere).  So my suggested workflow would be to output your own video files (if we are talking about original production stuff) from Final Cut with no compression at all (full uncompressed AVI or some such) and then run through Handbrake using the High Profile preset to an MKV container.  That ought to do the trick.


#6

Thanks Mike I will try using MKV then from Handbrake.  Can MKV play 1080p and at what frame rates?  For the record I am using a brand new 1TB WD Elements desktop HDD connected to the WD Live.  I am going to do a few tests and render out a short video clip to a few different formats and frame rates/quality to see how it plays back.  

Simon


#7

MKV is just a container, like AVI or MP4, so there aren’t any limitations on what it can contain.  If you use the default Handbrake High Profile preset it will handle everything else like frame rates, size of video, etc.  (except it defaults to MP4, so change to MKV, and also go to audio and make sure you just pass through the DTS or AC3 tracks if you have any.  You *can* use the default to convert to AAC, which the Live will play, but if you have better audio no sense in converting it).


#8

I have the same problem.

I find if you set the Video Settings to 1080p @ 60Hz in HDMI - then MKVs play smooth (Dvd ISOS and AVI files Shudder)

I then annoyingly have to Change to 1080p @ 50Hz to watch Dvd ISOs or Avi files smoothly.

Its a pain but it works for me

Good Luck


#9

I’ve been pulling my hair out trying to get 1080p 24fps movies from final cut that I create from my own DSLR video playing back smoothly on the WD Live. No matter what settings in Quicktime MOV I tried, I always got periodic frame freezes and slightly choppy playback.  Thanks to Mike’s advice I rendered the movie out as a 30Mbs mov file then using Handbrake I converted it to a mkv file. Not only did I end up with a smaller file size, but the result is stunning!  Bright picture, super sharp and contrast and most of all butter smooth playback.  THanks so much, now I have to rerender and convert everything else!

Simon


#10

Glad you got it working, Simon.


#11

You don’t have to re-render anything :slight_smile: The problem you’re describing is indeed caused by the fact that your WDTV is outputting the movie at an other framerate than the movie was recorded in. This is very noticable if a camera moves/pans fast, exactly like you describe (although the majority of the people doesnt notice it all !) Anyway, to solve it, simply set the WDTV to the frequency the movie was recorded in (you can change the frequency in audio/video setup and you can check the movie’s frequency with for example MediaInfo: http://mediainfo.sourceforge.net/ ) Of course, your TV has to support the selected frequency. If it doesn’t the WDTV will choose another frequency for you (although in the menu it will still show the frequency you chose).

WD already said they wanted to implement an ‘auto frequency switcher’ that switches the WDTV used frequency to the one in the movie you’re playing. If you don’t want to wait for that, you can use the one that was developed in the homebrew FW, it works perfectly: 

http://forum.wdlxtv.com/viewtopic.php?f=51&t=540


#12

SjefDeKlerk wrote:

You don’t have to re-render anything :slight_smile: The problem you’re describing is indeed caused by the fact that your WDTV is outputting the movie at an other framerate than the movie was recorded in. This is very noticable if a camera moves/pans fast, exactly like you describe (although the majority of the people doesnt notice it all !) Anyway, to solve it, simply set the WDTV to the frequency the movie was recorded in (you can change the frequency in audio/video setup and you can check the movie’s frequency with for example MediaInfo: http://mediainfo.sourceforge.net/ ) Of course, your TV has to support the selected frequency. If it doesn’t the WDTV will choose another frequency for you (although in the menu it will still show the frequency you chose).

 

WD already said they wanted to implement an ‘auto frequency switcher’ that switches the WDTV used frequency to the one in the movie you’re playing. If you don’t want to wait for that, you can use the one that was developed in the homebrew FW, it works perfectly: 

 

http://forum.wdlxtv.com/viewtopic.php?f=51&t=540

Can’t get this firmware. It tells me that I am not authorized to view the thread. Can you email me the firmware please?

dvdmtl@yahoo.com

thanks