How to make the WDMYCLOUD **bleep** less

Hi guys - posted this in the thread i started, but thought it might be useful here.

Was having serious lag, failures, and general frustrations.  Mostly hunting the forums collated a few fixes that make this reasonable peice of hardware stand a chance in light of its terrible, terrible, god awful, soul destroyingly bad software.


 Warning:  doing these basic proccess adjustments that make this product functional will probably void the warranty.


Hey guys

Quick easy fix to wd melting down every time you look at it.

1 - open terminal (or putty/linux terminal if you’re using windows)

2 - ssh root@(whatever IP address is of mycloud)

3 - say yes

4- password welc0me

5 - /bin/sh /etc/rc2.d/S86wdphotodbmergerd stop - turns off shirttily written thumbnailer

6  - /bin/sh /etc/rc2.d/S85wdmcserverd stop - turns off peice of shirt mycloud indexing.

basically these two peice of shirt processes are terribly written and just blow the reasonablish hardwares brains out.  

If you’ve got days when you won’t be using it, (i’m talking days upon days) let them run and it’ll finish indexing apparently.  Frankly I couldn’t be francked not accessing my data for that long

de suckify twonky (the media server bit)

1- go to twonky - advanced, ( http://wdmycloud.local:9000/#advanced))

2- go to rescan intervals

3 - change it to 0

4- save (at bottom) this stops it scanning itself completely every time a file moves.

5- go and rescan your database

6 - for bonus points go to sharing section, and specify the media folers on your drive and the types of content they’ve got.

If you make changes to your file structure go back to advanced  and select rescan.

By removing these processes and following the above steps your NAS will work ok.

In summary the software is written terribly and you’re better off turning it off till they write some code that doesn’t melt this poor little nas’s brain.  This then becomes a reasonable hard drive and home solution, with reasonable media streaming .  It will deactivate the cloud bit till you let WDMCSERVER finish.

bad form WD.  Be less terrible.  Also my ‘escalated query’ never got responded to, can’t wait to publish my blog which will be something along the lines of “how to make the WDMYCLOUD **bleep** less”.  I’m sure I’ll get tonnes of traffic.

Any other tips/tricks to optimise this garbage bag of woe?

1 Like

sorry left this out, first three steps before you can access via ssh

1- Through your browser, go to  http://wdmycloud.local/UI/

2- login and go to settings

3 - turn SSH on

and for the curious, here’s the finished review