How to hide the Virtual CD (VCD)

How to hide) the Virtual CD (VCD) for Windows 10 so the drive letter does not show in file explorer and the drive is still active so it will still unlock my drivewhile plugged into my laptop

Go to Device Manager and look for the smartware VCD then right click and disable. See if that works I think that’s what I did but it was a long time ago.

I got my 6 Tb My Book yesterday. When I mounted it , it shows a virtual CD and the drive . I did as you said and now it works fine. Thank’s