How to get the myCloud gen 2 into safe mode?

So I upgraded the device to OS5 and I want to put it into safe mode to revert back to OS3.

Does anyone know how?

Maybe the directions user Fox_Exe put together for unbricking a second gen single bay with the OS3 v.2x firmware may work. Of course proceed at your own risk and backup any user data prior to attempting any of the methods explained in the following link. One probably will need to skip the step in the directions that creates the partitions and formats them. That step is typically only needed when unbricking a new hard drive for use in the second gen single bay My Cloud enclosure.

Second gen directions:
Alternate method files:
Latest second gen firmware:

Note: I do not have a gen 2 single bay My Cloud so no idea if this is even possible to revert at this point to the earlier OS3 firmware without doing a complete wipe of the drive and starting from scratch. Do not blame me or anyone else for any data loss or problems when attempting to roll back to OS3 from OS5!

If you find a way place it here. Did you read the information about updating?

*** This is a one-way update. Users will not be able to roll back to My Cloud OS 3 from My Cloud OS 5**

My Cloud OS 5 Limited Public Release Now Available for More My Cloud Devices! - My Cloud OS 5 Personal & Network Attached Storage / Announcements - WD Community

I have a V1 MyCloud. . . and I have no intention to play with the system firmware.

From what I read in the OS/5 forums; what Bennor is suggesting above is in the right direction.

Looking at the Fox_exe instructions, what he is basically doing is

  • wiping the drive
  • loading recovery firmware
  • rebooting (and after rebooting, the recovery firmware will have you load proper firmware)

From what I can tell, you might not need to do ALL those steps.
Installing OS/5 does not appear to change the partitions or change the existing recovery firmware system.

The key step I believe is to wipe the OS (the Linux kernal) from the partition that it resides in. . . and then upon reboot the existing recovery firmware will “see the problem” and prompt you to load new firmware.

Now clearly, one needs to be careful. Afterall, your data sits on one of those partitions. I do not know if the basic HDD architecture of the MyCloud is similar to that on the newer NAS devices. And I have not tested any of this (nor do I intend to test it). . . .so. . . . .user beware

And yes. . . .cat0w is correct. . . . .for several reasons (I can guess, but do not know), WD is NOT providing a downgrade path. . and they are clear from the start this is a one-way road.

I found the debrick method last night. I’ll try it out later today and post back. I need a small USB stick as all of mine are 256gb at this point. If I can’t find a solution to this I’m going to junk the drive so I don’t mind if I have to go the experimental route.

I have some experience doing this from the asus eee pc days so I might just put on alpine linux which will be a win as long as I can put transmission on it and not worry about it.

ok I have gen2 mycloud from following most of the directions in Fox’s I have successfully gotten it into recovery mode.

I did every instruction except for reformatting the hard drive (as there’s nothing wrong with my drive other than OS5) so that skips about 12 instructions.

I’m on a mac so telnet was a little dicey so I ssh’d into my raspberry pi and then from there telnet’d into the wd mycloud gen 2 and ran the recovery instructions. Unplugged the drive removed the USB drive (this is missing from the instructions). Logged back in via web browser and got the recovery screen that lets you install any firmware.

Only problem so far is that the empty log in for admin didn’t work and neither did my old password. So I had to do a 40 second reset as the 4 second one never seems to work for me which would make sense as you had to create a new cloud account under OS5 and the 40 sec one resets it.

After you do the 40 second reboot it’s an operational OS3 and you can do whatever you want.

Also since you don’t reformat the drive all your data is still there. I did have to reinstall the third party hack and apps because they vanished.

If anyone has questions feel free to ask. I’ll post something similar in the OS5 section in case anyone has a similar problem.

Glad it worked for you. . . .

A big Warning Since OS5 update 5.11.112 at least you are not able to revert back or downgrade to OS3. Using FOX’s dd if=/dev/zero of=/dev/mtdblock1 will give the recovery mode page indeed but the page does nothing, you won’t be able to upload OS3 or OS5 firmware, you will be left with a bricked device. Only way to recover the device is via UART connection to the board and even then you can only bring back your device to life to OS5 only no downgrade. I can confirm this for the MyCloud Mirror Gen 2, I haven’t tried it on My Cloud Gen 2 but I believe the situation is the same, no recovery option. If WD Staff is reading my post they should try and fix this issue, if your firmware gets corrupted you indeed get a recovery page to upload the firmware which does nothing.

I was able to do it with the fox_exe method… But I have a bug and I’m not able to resolve it.
Everytime I reboot the WD MY CLOUD gen2, I get the configuration screen like the first time. I have to set up the sharing folders, Add users…

Did you do a 40 second reset after fox’s method? I found that missing or an added step.

OS5 has a different user system than OS3. So I had to do the soft reset the device after wards. Although when I reverted back to OS3 I skipped some steps to save my data.

Have you tried telnet? I did it with telnet. Although I am not sure which version of OS5 I installed. And I didn’t use dd to change anything.

Using telnet had a steep learning curve if you don’t use SSH. But if you do, you basically need to scan your network for the NAS (as it has a different IP address than normal – this threw me off for an hour or as I kept trying to telnet into the old IP address and being that I didn’t really know how to use telnet, I didn’t know I was doing anything wrong) but once you get past that it is kinda easy. (BTW, finding all this software on a mac was a different pain in the butt but there’s not many that even claim to do it so you’ll have to download less than 6 pieces of software to figure out the right combination unless you know what you’re doing or already have it).

is it important to do it ? I will try it.
I skipped the format line too.
When I was doing the downgrade. I opened The router page and I was watching live the IPs of wired devices. So I didn’t lost time when the WD change the ip.

you can check my steps in this topics

Yes, that is often the final recommended step after booting the device the first time, when one performs those directions even though it’s not specifically listed in the directions.

Either a 40 second reset, or if one can access the My Cloud Dashboard, performing a System Only Restore (My Cloud Dashboard > Settings > Utilities) is often needed after performing the “unbricking” directions user Fox_Exe created for both the second gen and the first gen single bay My Cloud.

Telnet was not available/not working anymore. I only got the safe mode page to upload the firmware but nothing happened no matter what browser I used or platform Windows, Mac, Linux. Like I said the only way to recover the NAS was to connect through the UART connector. And even then I was only able to restore OS5 version. So if you’re not ready to solder or break open your device be careful because you’re not able to recover your briked My Cloud otherwise. I can say for sure since which version of OS5 reverting to OS3 became impossible but I was on OS5 v. 5.11.112.