How to get rid of wonky twonky?


#1

The ShareSpace is slow enough as it is. Mine (4T) also has Twonky enabled. Ilooking at top I see this

 root     R <      10M  1020 73.8  8.8 twonkymediaserv
3756 root     R        788  3466  1.1  0.6 exe
 2063 root     S        756     1  0.5  0.5 WiAutoConfig
 2879 root     S <      11M   896  0.0  9.0 smbd
 1054 root     S <      10M  1020  0.0  8.8 twonkymediaserv
 1000 root     S <      10M   999  0.0  8.8 twonkymediaserv
 1046 root     S <      10M  1020  0.0  8.8 twonkymediaserv
 1020 root     S <      10M  1000  0.0  8.8 twonkymediaserv
 1049 root     S <      10M  1020  0.0  8.8 twonkymediaserv
 1048 root     S <      10M  1020  0.0  8.8 twonkymediaserv
 1052 root     S <      10M  1020  0.0  8.8 twonkymediaserv
 1044 root     S <      10M  1020  0.0  8.8 twonkymediaserv
 1045 root     S <      10M  1020  0.0  8.8 twonkymediaserv
 1047 root     S <      10M  1020  0.0  8.8 twonkymediaserv
 1983 root     S       9812     1  0.0  7.7 cvm

This seems quite inefficient that so many instance of something I don’t use should be running on what is already a sloth.

How do I turn the **bleep** thing off?

Thanks


#2

ssh to sharespace and paste the command

/etc/init.d/S97twonkyserver stop


#3

Could you give an example of the SSH syntax to login to the NAS?   My *NIX is rusty to say the least (I have four *NIX books, all to old to even mention SSH).

Also, will that permanently disable Twonky or will Twonky restart if the NAS is power-cycled or rebooted?

Thanks,

jb


#4

Login under root through SSH and execute the following:

chmod ugo-x /etc/init.d/S97twonkyserver

or

To manually stop a Service you can run the command “/etc/init.d/S97twonkyserver stop”. When you would like to Disable the Service rename the File and put a “_” in front of it. (Command “mv S97twonkyserver _ S97twonkyserver”). Reboot the NAS when you have changed and check on the Console with “ps-aux” that the Service has not been started anymore.

To enable the Service again just remove the “_” and restart the NAS.


#5

Thanks, chmod did the trick.

I would really like to get rid of the other stuff I don’t need:

“WD_Backup” user and share

“Download” share

I got this NAS for a singular purpose and all this just clutters the interface for my users.

However, what progress I’ve made on that seems to be getting overwritten by SxM_webui ( not really excited about mucking about in there).

I appreciate how plug-and-play it was out of the box, but I wish “Advanced Mode” was just a little more advanced…

Thanks again,

jb


#6

supwner wrote:

ssh to sharespace and paste the command

 

/etc/init.d/S97twonkyserver stop

 

No, doesn’t work for me.

If I take ownership the service will stop but then I loose the web interface to the sharespace, forcing a reset and the cycle starts over.


#7

It did the trick for me and the performance are much improved!

I had to login as root (psw welc0me) and not ‘admin’. Then /etc/init.d/S97twonkyserver stop. Last - don’t forget to rename it and remove the x permission so it won’t start next time you reboot.

Thank you!


#8

All this should be possible from the gui, would be nice if some one made a list or some scripts that we could execute so that its easier for us non ssh pple.


#9

Umpa2011 wrote:

All this should be possible from the gui, would be nice if some one made a list or some scripts that we could execute so that its easier for us non ssh pple.

According to the FAQ elsewhere here, http://<sharespace_url>:9000/rpc/stopserver  should stop the  unwanted servers.


#10

  http://<sharespace_url>:9000/rpc/stopserver  doesnt keep the server shot down. Twonky starts up again once you restart the sharespace. We need a permanent solution.


#11

AKazak wrote:

Login under root through SSH and execute the following:

chmod ugo-x /etc/init.d/S97twonkyserver

 

or

 

To manually stop a Service you can run the command “/etc/init.d/S97twonkyserver stop”. When you would like to Disable the Service rename the File and put a “_” in front of it. (Command “mv S97twonkyserver _ S97twonkyserver”). Reboot the NAS when you have changed and check on the Console with “ps-aux” that the Service has not been started anymore.

To enable the Service again just remove the “_” and restart the NAS.

    • *> what is the command for renaming it back to original? I have tried “mv S97twonkyserver S97twonkyserver” but am told that there is no such file or directory.

#12

well if you ran the command exactly how you posted it here then you get the file doesn’t exist error because you renamed the file you are referencing to start with an underscore.  to reverse it you would need the first filename to have that underscore too.