How to get data from the good drive of a failed RAID1?

I have a WD MyCloud EX2 4GB and Drive1 has failed and thus RAID1 is now degraded. Drive2 is good though. How do I copy my data off the good drive? I don’t want to replace the bad drive as I already have new storage I want to use.

I just need be to able to get my data out but the drive shares no longer seem accessible, although I can still connect via my LAN to the dashboard. Is it possible to copy from the good drive without buying anything else?

You will probably need to replace the failed disk to get the unit to work properly

probably an idea to find a larger model with more disks that are easier to work with when disks die

I am confused. . .isn’t the entire point of Raid1 to be able to use the one good disk while you get and replace the bad disk?

UNLESS. . .both disks are bad. . .in which case. . . .

Replace the bad drive and do a raid rebuild from the good drive.

Then BACK UP YOUR DATA.

I want to ditch both drives since I already bought a new MyCloud Ultra that’s twice as big. Is there any way to get the data off the remaining good drive without buying a brand new drive that I would solely use to do a one-time extraction of data?

I just spoke to customer support and they confirmed that the only way to get my data off the good drive in my RAID1 is to buy a new drive to replace the bad one and rebuild the RAID1.

Does my newer MyCloud Ex2 Ultra 8TB work the same way, where I can’t use it if one drive dies in RAID1? Are there any competitor products that still have the data accessible if half of a RAID1 dies?

This all just sounds wrong.

We need others to chime in. . . in a raid one configuration I think you should STILL be able to access data from the good drive.

SO. . . at this point. . . I would do the following.

  1. Panic. Spend 10-30 minutes in a panic attack. Get it out of your system. Once “panic” is complete. . .proceed to the next step.

  2. Recover: I would get a USB enclosure; pull the GOOD drive out of the NAS, and attempt to access the data. Note that the drive is formatted EXT4; so won’t be readable without obtaining a Linux reader program. But you should be able to read data this way.

  3. Crazy talk: Take one of the large drives out of the new unit; and install it into the old unit; and let it rebuild the array. It will be the “smaller” size array. Once this is complete; you can access the data on the system; and back it up to a secondary system.

Note that this step requires a successful copy of all the data on the old drive to the new drive. If the old drive is flakey. . … .this might not work. If you only have a limited amount of “read access” left on the old drive. . . spend it in the USB enclosure copying the data off in step two

  1. More Crazy talk: With a functioning raid in the old enclosure, take out the two disks; install into new enclosure. You should be able to IMPORT the disks using the RAID ROAMING feature. You should now have a reduced size raid1 in the new enclosure.

  2. Really: This is going somewhere: Replace the old drive with the second new drive you had gotten with the new Enclosure. You should be prompted to rebuild the array using the new drive. END RESULT: All data on both drives; but raid array configured to the smaller size of the ORIGINAL array from the old enclosure.

  3. Pay Off: Do a raid volume “Expand”. There should be a button to expand the array to utilize the full capacity of the new disks. Note that this procedure is just an extension to a procedure of expanding a system in an enclosure It should work.

IMPORTANT NOTE: All of this is free advice from a random dweeb on the internet. I have never done any of this. Net value of this advice is equivilent to the payment I have recieved.

Hi there, I am facing the same situation today but with a failed Drive 2, while RAID1 is degraded and Drive1 is good.

Just wondering if you were able to get your data off of the good drive onto a new MyCloud? (without having to replace the failed drive)

Any tips/advices in transferring the files to a new MyCloud?

Thanks in advance!

I ordered this replacement drive off Amazon.
WD Red 2TB NAS Hard Disk Drive - 5400 RPM Class SATA 6 Gb/s 64MB Cache 3.5 Inch - WD20EFRX (Renewed) https://www.amazon.com/dp/B07DZ1KH6Q/ref=cm_sw_r_cp_api_glt_i_6114YNV39GQE2J6RGDS1?_encoding=UTF8&psc=1

However, after putting it in I still can’t access my data. The option to rebuild the degraded RAID1 is missing from my dashboard. I worked with tech support chat yesterday who in the end said that a higher level of tech support will have to call me in 1-2 business days. So I’ll update you later this week assuming they call as promised.

Right. . . . . .something is seriously not right. You SHOULD be able to access data on a given drive with a the other degraded drive physically removed. It sounds like something is odd with BOTH drives.

Seriously. . . start thinking about data recovery from either drive.

PS: 2TB Red: $90 for refurb??? It’s likely SMR. Suggest you return and replace with Amazon.com: Western Digital 2TB WD Red Plus NAS Internal Hard Drive HDD - 5400 RPM, SATA 6 Gb/s, CMR, 128 MB Cache, 3.5" -WD20EFZX : Electronics

The whole point of RAID is to be able to read and write during a hard disk failure - albeit it will be at a lower throughput depending on the type of RAID you chose.

Recommendation is connect a USB B disk directly to the device and copy using the Admin console. Do not present the USB device as a share because behind the scenes the data will go over the network twice. If you do want to copy the files to your computer instead, don’t use Wifi as the Wifi caps out at about between 1 MB/s and 30MB/s depending on how far you are from your router, number of devices, etc. Use a wired connection instead.

You also can rebuild your RAID at the same time you are copying files - however the speed of both rebuilding and file copying will be reduced.

Connecting a USB B disk is a neat idea that hopefully could help someone else in my situation. For me I had to go to a data recovery specialist, DriveSavers.

i have same issue happen yesterday,
from disk status said “BAD”,
i tried to go to tap call “APPs” and get the NAS-NAS backup all my data.

logically for raid 1, when drive 1 is degraded , Drive 2 should be able to use directly,
please correct me if i am wrong.

thank you

Logically, yes. With this device, no.

What exactly do you mean by “copy using admin console”?

The Admin console is the way you access the device directly. Mine looks like this.

If you go to the APPS tab - you can install the USB Backups application.
Once your USB device is plugged in - it will be available to write to in this app.

To get to the admin console you’ll need to know the IP address or device name of your device and use a web browser to connect. http://devicename or http://ip_address

You’ll be prompted for username and password - you would have set these when you set the device up.

OK, thanks. I can get to the dashboard no problem. Didn’t know about the app to do copying.

Unfortunately, now that web access has been disabled, I won’t be able to download any of the old apps.

Web access should not be disabled if you’re on the same network as your device. The Web access you might be referring to is remote access from the Internet or another network.

Yes, but aren’t the apps downloaded from the WD website (over internet)? There don’t appear to be any options to install a usb copy app in the “apps” tab.