How to get Arabic subtitiles working with the WD TV live


#1

Hello,

I have a video file that I’ve muxed into a matroska file with english subtitles, and arabic subtitles (both .SRT). The english subs work fine, but when I select the arabic subs all I got is a load of garbled characters. I have selected Arabic under the “additional encoding” option in the WD TV settings menu.

The same happens when I open the file with notepad under Windows.

Any ideas on what I’m doing wrong?

Thanks!

Odai.


#2

:stuck_out_tongue:

I’ve been trying all day with no success. No idea where I’m going wrong…


#3

OK, I’ve tried Unicode UTF-8 and it has made no difference.


#4

Ok, I’m confused.  You say when you open the Arabic subtitle file in Notepad, you see garbage THERE, too?   


#5

Apologies if I wasn’t clear. Yes, the text in notepad looks exactly the same as it does on the WD TV live, no matter how I encode it (options in notepad appear to be ANSI, Unicode, UTF-8). When I open the file in word and select arabic encoding, the words show but they are backwards. :cry:


#6

Sounds like your files are corrupt to begin with.  Don’t think I’m going to be able to help you out with that… :frowning:


#7

Hello,

I’ve been doing some testing, and I’ve learnt a little more about the problem.

It turns out the files that you describe as being “corrupt” would work almost 100% fine when I add Arabic to the language options in Windows. I think these were UTF-8 encoded. The only problem I now get with these is that some of the punctuation is backwards, for example commas. Brackets are also out of place and ellipses (3 dots) come out before the word, rather than after (when reading from right to left).   

There are other files that work fine either way (with or without Arabic support on windows), but I am not sure how these are encoded.

Any ideas on how I can fix this “punctuation” issue?

Thanks!