How to free some rootfs space without lossing my data?

I am having issue with rootfs been filled and need to free some space without lossing my data, any advice?

rootfs space.JPG

Welcome to the Community.

Please note this is a highly critical procedure that may affect your device. This is not supported by Western Digital, and as such extreme caution is recommended.

First thing - do " apt-get clean"

Next step - use command like this for search huge files/folders:

du -sh * | sort -h

@Fox_exe Thanks for your inputs

I ran the 2nd command and below is what I got, any advice?

15M etc
30M lib
50M opt
173M CacheVolume
230M var
853M usr
50G DataVolume

Below is what I get when I run df -h, I believe its more to do with transmission configuration, below I provided the path for transmission and where the download path is! Appreciate your help…

WDMyCloud:/# df -h Filesystem Size Used Avail Use% Mounted on

rootfs 1.9G 1.3G 557M 70% /

/dev/root 1.9G 1.3G 557M 70% /

WDMyCloud:/# find -name Transmission
./nfs/Public/Transmission
./DataVolume/shares/Public/Transmission

settings.json download folder parameter set to 

“download-dir”: “/DataVolume/shares/Public/Downloads”,

@yabdali

70% usage of rootfs is still ok. I can see your screenshot now. The problem seems to be with /var/log.hdd.

Do the find again in this /var/log.hdd to look for files >= 512k. Usually those *.log.[0-9] are safe to be removed.

230M var
853M usr

850+ MB on /usr - not good. I think its Twonky cache or something else.

du -sh /usr/share | sort -h

Fox,

Sorry for the late response. Tried your suggested command, below is what I got! Any further advice? Thanks
/usr/share 184MB

@Fox,

I just drilled down to the place where the space is been consumed. Apparently I did some installations and the lib folder got filled as per the details below. What’s the safest way to reinstall the WD firmware without resetting my system configuration or lossing my data? I am aware any third party stuff will be gone but I want to keep my configurations and data.

Thanks for your help…

WDMyCloud:/usr# du -sm * | sort -nr
424 local
184 share
141 lib
86 bin
21 sbin
1 src
1 include
1 games
0 orion
WDMyCloud:/usr# cd /usr/local
WDMyCloud:/usr/local# du -sm * | sort -nr
325 lib
53 wdmcserver
35 bin
8 twonkymedia-7
2 include
1 src
1 share
1 sbin
1 orion
1 nas
1 games
1 etc
1 NSPT
0 man
WDMyCloud:/usr/local# cd /usr/local/lib
WDMyCloud:/usr/local/lib# du -sm * | sort -nr
310 libmozjs-24.a
14 libmozjs-24.so.
1 wdAutoMountLib.pm
1 site_perl
1 python2.7
1 pkgconfig
1 libupnp.so.3.0.5
1 libthreadutil.so.2.2.3
1 libixml.so.2.0.4
0 libupnp.so.3
0 libupnp.so
0 libthreadutil.so.2
0 libthreadutil.so
0 libmozjs-24.so
0 libixml.so.2
0 libixml.so
WDMyCloud:/usr/local/lib#

I have fixed the issue by reapplying the last update using the script updateFirmwareFromFile.sh and the cached update file in /CacheVolume/updateFile.deb