How to format a MyBook live? and other questions

My MBL is new. After pluging it, I followed the steps. Asked me for firmware upgrade and I agree.

After that, It has been initializing for ever. I’ve followed some great guides to solve this but the led is still yellow-white.

Here are the details

-I can access the MBL trough the finder (I’m using a mac). No problem at all…

  • I can access the dashboard, but it hangs in the “Initializing device. Please Wait…”

  • I’ve manage to enable the SSH, and I can use it.

I have already tried reseting it, restarting, following several very good guides. So I have a couple of questions for any good soul:

a) How can I format the HD un the MBL (2 tb model)

b) I do not mind not accessing the dashboard, (I’m tired of trying) but is it unsafe? Is there anything to be done to “Secure it” in any other way?

c) I might not be finding the right guide to solve this “Initializing device. Please Wait…” problem?

Thanks in advance for your time and help.


Have you tried performing a quick factory restore?

Also you can send a Pm to nfodiz, he might be able to assist you further.

travelero, PM me if you haven’t resolved this issue as I think I can help