How to disable EX2 from appearing in Windows Network and Sharing

Hi, I’m a new owner of an EX2 and not a techy guy. Apologies in advance for a noob question. My EX2 is all new and I’m not sure what version firmware its running on (will find out later how to check for that).

The problem is this. My EX2 appears in the Windows Network and Sharing once it is plugged in to the LAN at my workplace. And it seems to appear on everyone’s PC on the same floor (network folder). I found out from trusty Google that I can turn off the Network discovery and file sharing from my desktop PC, but not for the EX2.

So is there a way to disable, hide or remove my EX2 from appearing in Windows Network and Sharing to everyone on my floor?

I’m sorry if I missed something but i’ve been searching the posts here and didn’t find anything. Not sure if this relates to the public sharing issue. Please help.



Try creating a separate workgroup for the computer and the Mycloud.

Don’t put any files in the Public folder, create a folder outside of it and password protect it.  Will show but only those with the password can access the contents.

What you want,needs a firewall inside the WD EX2, to restrict access over the LAN

So if want this feature be added , please vote here