How to decrypt a WD MyBook drive after its removed from the enclosure?


#21

If you remove the drive and connect to a linux computer via SATA or a nonWD enclosure, my technique works more than 90% of the time. It works for drives that have one of these chips on the USB-SATA bridge card: JMS538S, SW6316, INIC-1607E, and OXUF943SE.

There is also a project at github.com/andlabs/reallymine for other operating systems.


#22

Hi Thomas
I have just had a WD “My Book Essential” with a 1.0 TB SATA/32MB Cache drive fail. It has a lot of photos and personal data I would like to recover.

Process so far:

  1. Noticed drive did not show up in Win explorer anymore.
  2. Checked power supply, OK.
  3. Removed drive from casing and connect to spare SATA cables on PC running Win 7 64x.
  4. Run Win drive manager, drive not recognised, shows up in win devices as a WD drive but not accessible.
  5. Run free version Minitool Free, Stellar Phoenix, did full scan with each. Stellar recognised, found only a few files.
  6. Drive is now viewed as a drive with letter designation in Win explorer, however it says it must be formatted to use it.

The drive was using Symwave chip SW6316-3VB14. I believe this chip has died, as drive is still mechanically functional, and spins quietly.

Any advice, help would be much appreciated, thanks.

Thanks

Jumma


#23

I’m sure that Windows has already corrupted your MBR and the headers
of your data partition. When will people learn?

I can only tell you how to decrypt if you use linux. If you use Windows,
try github.com/andlabs/reallymine for a program that has a Windows version.


#25

I am currently downloading and preparing a USB for Ubuntu as a live stick to boot from.
Do you have directions in Linux to recover as a SATA connected drive?
Thanks
J


#27

Hi Thomas
I decided to go with a local data recovery company.
They charged AUD$150 and were successful at recovering all 1.0 TB of data … phew!
I will have extra backups offline of all this data in future.
Thanks
James


#29

Hi All,

I have a WD hdd here from a friend who has said that the usb bridge has failed.

It is an inic 1607e chip

How would I go about recovering the encrypted data?


#30

A first step, could be to write to: http://support.wdc.com​

But everyone must remember that any hard disk (or anything else) may
finish, anytime, its life and therefore backup are a must.


#31

I put my tutorial here.

Notes:

  • If you connect the bare drive to Windows, it will automatically corrupt the MBR and partition table.
  • Tools for password recovery are not included.
  • I am looking for more JMS538S keyblocks for a project. If you have such a drive, please send me your keyblock (and password, if any) and a copy of your sector 0.

#33

Hi @thomas_kaeding ,

I’ve got a WD My Book Essential (P/N: WDBACW0030HBK-00 4511D) that I believe is having the same issue. It seems to power on and spin up when plugged in, but is not detected by either windows or linux (from within the enclosure, I haven’t tried getting it out of there yet).

I downloaded your github guide and have been reading the PDF, but I’m not quite sure where to start, for instance how can I tell if my WD is using one of those specific chips mentioned in the PDF?

Hopefully this isn’t a dead thread and someone sees this, otherwise thanks for all the work you guys have done on this already!


#34

The chip number is printed on the chip. The chip is on the board
that you removed when you took the drive out of the enclosure.


#35

Yeah, I finally removed the enclosure, I was trying to see if I could find
some spec sheet online that would mention it but nothing did.

On the chip it says “symwave SW6316-3VB14” with some stuff under that. I
believe that’s a chip covered in your PDF, so I’m going to give this a
shot. Just got a new Linux Mint 18.2 64-bit install going, so hopefully
this works!

Would it be ok if I sent you any questions that might come up?


#36

@thomas_kaeding

So I went through everything mostly smoothly, until the end. Would it be possible to e-mail some questions?


#37

Read the README.md file. Only if you TRIPLE-CHECK that you
made no typing errors, open an issue on the site, with the
requested information.

Most questions turn out to be typing errors, and I don’t have time for
that any more.


#38

If your WD controller ist recognized but the disk is seen as “unititialized” this might be interesting for you.

I had the same issue that WD Book Essential was not working anymore.

In my case, the system (Windows) recognized the disk, saying it is “uninitialized” and initializing failed with an error message “Device not ready”.
The disk itself did not spin up, so I assumed the power supply was dead.
Using another power supply did not help.

I took the disk out of the enclosure and connected it to a sata usb adapter.
The disk worked and I saw nothing - this is where I came to this site to find out that it was encrypted.

Then I figured the controller might be OK but cant get enough power to the disk for spinup.
So I connected the disk to a different power source and only the sata connector to the controller board. (I had to remove the power socket with a saw to be able to connect another plug. - If you have a sata extender cable you won’t need to do this).

Now the controller was powered by the original power supply and the disk was powered by a different PC/SATA power supply.
This way I managed to get the disk working as usual and could take a backup without needing to decrypt it.

Hope this helps.


#39

@SBrown Will I still be able to find wd20earx?

(South Africa)


#41

Hello @Henrik_Berg, could you please tell me how I can contact Thomas ? I’m looking for his assistance (even paid) for the same issue.


#42

Hi

Here’s the e-mail i used to contact him.

Edit: Removed e-mail


#43

Got it. I think it’d be safer if you edit and remove his e-mail from your post (nor spammers will find it).
Thank you very much Henrik!


#44

Hi how are you? I have troubles with a Wd my book . I wonder if you could help me out. I am willing to pay you if you have time. Thanks.


#45