How to decrypt a WD MyBook drive after its removed from the enclosure?

What do you guys think is too expensive? What are the DR pros charging? Can they actually decrypt the drive?

I have also managed to do this for a drive using the Symwave 6316 chip.

Again, only in linux.

1 Like

I just want to say that Thomas saved my precious data. He helped me to decrypt my WD My book via email. He spent hours helping a noob like me doing all of this in Ubuntu. I have never used any version of Linux before, so I must say it was very interesting. My drive had a Symwave chip and it worked. The first sector was also corrupt so he helped me with that aswell. I sent my first e/mail at 1 PM and it was solved at 1 AM. So I must say he was fast and very professional. He did it completely free of charge to. Amazing! Thanks Thomas!

2 Likes

I want to say to everyone that Thomas Kaeding helped me save all the data from a friends hard drive. It was a MyBook Essential 2TB USB3.0, model number wdbacw0020hbk-00. The USB-to-SATA board fried and did not start the disc, nor it got recognized by the computer. I testes with different power supply and USB cable and nothing worked. This board has a Symwave SW6316 chipset which applies hardware encryption of AES-256 to all data. After a few minutes of sending the disc blocks containing the key to Thomas, he was able to point me with the unscrambled key and how to use it in Linux (I used Ubuntu Mate).

This guy deserves to be contracted by WD and receive big money from them. WD should provide a tool, made by this guy, to help all the people solve this problem in the event of a failed external case. This is a well known problem and many people loose invaluable data because of this problem. If this only works in Linux, at least WD should provide a virtual machine made from this guy, so that people can retrieve their data. After that, the drive can be formatted and used without encryption, in a typical USB-to-SATA external case.

Thank you very much Thomas! I hope someone from WD sees this and takes the action of contacting you so that you receive the credit you deserve, and also the monetary compensation.

1 Like

Guess what? I’ve just got help from Thomas decrypting and recovering files from an old MyBook drive with a faulty USB interface. His procedure worked also in my case with the INIC-1607E chip flawlessly.
I agree with the ones saying that Thomas should be paid by WD for the service he’s providing to their customers!

Thomas helped me decrypt my hard-drove as well; the controller board on my essential died and he had it fixed within a few e-mails. Thank you very much! 10/10

I am suffering a similar calamity. If anyone who has figured this out could give me some pointers it would mean the world! :slight_smile:

I’m currently using ddrescue to try and clone my failed drive to a spare so I can try to repair it and retrieve some very important pictures, and I wouldn’t be able to do that if it wasn’t for Thomas’ amazing help with the encryption and the very detailed use of commands. In my experience it’s rare that someone is so helpful to someone they don’t even know. Thank you very much, Thomas!

I also am having the same issue, if anyone could give me some pointers as well, I’ll love you forever! I’ve tried everything I know to get this to work, but am at wits end!

In a nutshell, if you have a hardware encrypted My Book Model XYZ, and the enclosure fails, all you need to do is obtain the exact same enclosure from XYZ and insert the drive.

Hope this KBA helps clear things up regarding hardware encrypted My Books vs My Book with RAID and reading the drives on a regular PC

How can I determine the enclosure model if it has since been lost and I only have the drive?
This is a 500 GB WD Caviar GP WD5000AAVS - Can you tell me which model I will need to get?
The link does not provide this information.

@Rob_Wicked We’ll update our KBA for more instructions and solutions.
On the single bay units, the S/N of the drive matches the S/N of the enclosure.
Enter your drive SN here and it should pull the My Book part number

Thank You.

I recommend removing the S/N from the public forum, but since you posted

WDH1CS5000N
My Book Home Edition

@SBrown: What would be the process for obtaining a new controller? Since opening the drive enclosure to determine whether it’s the SATA-USB bridge or the drive voids the warranty, how does one go about getting a new enclosure out of warranty?

@PATRICK_ROWLEY source a used or new enclosure with the same product number

WDH1CS5000N
My Book Home Edition

If you remove the drive and connect to a linux computer via SATA or a nonWD enclosure, my technique works more than 90% of the time. It works for drives that have one of these chips on the USB-SATA bridge card: JMS538S, SW6316, INIC-1607E, and OXUF943SE.

There is also a project at github.com/andlabs/reallymine for other operating systems.

1 Like

Hi Thomas
I have just had a WD “My Book Essential” with a 1.0 TB SATA/32MB Cache drive fail. It has a lot of photos and personal data I would like to recover.

Process so far:

  1. Noticed drive did not show up in Win explorer anymore.
  2. Checked power supply, OK.
  3. Removed drive from casing and connect to spare SATA cables on PC running Win 7 64x.
  4. Run Win drive manager, drive not recognised, shows up in win devices as a WD drive but not accessible.
  5. Run free version Minitool Free, Stellar Phoenix, did full scan with each. Stellar recognised, found only a few files.
  6. Drive is now viewed as a drive with letter designation in Win explorer, however it says it must be formatted to use it.

The drive was using Symwave chip SW6316-3VB14. I believe this chip has died, as drive is still mechanically functional, and spins quietly.

Any advice, help would be much appreciated, thanks.

Thanks

Jumma

I’m sure that Windows has already corrupted your MBR and the headers
of your data partition. When will people learn?

I can only tell you how to decrypt if you use linux. If you use Windows,
try github.com/andlabs/reallymine for a program that has a Windows version.

I am currently downloading and preparing a USB for Ubuntu as a live stick to boot from.
Do you have directions in Linux to recover as a SATA connected drive?
Thanks
J