How to customize Photos / Music / Videos Home Screen Tabs


I have a WDTV Live with the latest firmware.  I have a Synology DS411 NAS, which offers SMB and DLNA media serving.  I need to configure my WDTV Live to be REAL SIMPLE for my wife and kids.  More specifically, with DLNA turned on, in the Photos tab, it shows the default shared folders on the NAS (video/photo/music).  It is the same with the Video and Photos tab.  In a perfect world, the WDTV Live would only show the DLNA shared photo folder in the Photo tab.  Same for Videos and Music.  It would be nice to drill down and set a root somewhere.

I turned off the DLNA services on my NAS, and turned on SMB.  I am having the same problem here, meaning the WDTV Live won’t let me drill down.  It shows all of the available shared SMB folders.

Has anyone else come up with a creative way to root certain folders and/or media types to their respective WDTV Live Tabs?


Paul c.

Sorry I don’t have an answer - just wanted to say I have the same problem - so you’re not alone. Whatever I select Photos or videos or music, I always see Shared and I have to drill down.


Using the DLNA feature between the WDTV and a WD Mybook Live (using Twonky) only shows the media you select. 

So presumably there’s some minor incompatibility between your Synology DLNA server and the WD…


Can you tell me what the structure of your MyBook is? i.e I have a Shared folder - in there I have a Video, Photo and Music  folders.

I select video on the WD menu and select Network Share - but I only do that once, when I go into photo or music the dive is already seen and I see the top level Shared folder.

Can you explain your folder structure, and then your sepup, so that we can maybe spot where we are going wrong?


We’re talking about two different things now.   I was referring to DLNA access, not network share access.

With Network Shares, since you have the possibility of multiple servers, it’s always going to begin with the SERVER NAME (if you have multiple servers) then the SHARE NAME (if you have multiple shares on that server) , and then the folders within that share.

That’s if you’re using the “FOLDER” filter.

It makes sense if you think about it.  If you happen to have two servers, both with a share called “VIDEOS”, if it didn’t begin the navigation with the SERVER folder, then you would first be presented with TWO folders called “VIDEOS.” You would have no idea which was which.  This would be rather dangerous if you were using some of the extended options like “Move / Copy / Delete…” etc.  You would have no idea which file was which.

Based on the way the Media Library is built, it has to guarantee that two files are unique.   The only thing unique in the case above is the server name, so it’s always going to include the server name (or share name) as part of the navigation path.

There are only two ways to prevent the SERVER from showing up first:

  1.  Use only ONE SERVER, and no external drives.

  2.  Use a different FILTER method other than FOLDERS.

Tony many thanks, sorry if I’m missing the obvious, but the filter (green) button does not seem to appear everywhere.

Is there a process whereby I can get my desired effect? Or is it the nature of a NAS that all will be seen by all?


The GREEN button is only available if you’re using Network Shares or My Media LIbrary.   It’s not available with DLNA sources becuase the SERVER is control of content organization, not the WD.

This gets more confusing - I have used Network Share to link to the NAS, but I’ve also turned Media Library on - I thought that was needed for indexingwhat was there.

Is there another way to see the NAS other than via Network Share that will allow the desired effect? [and before you say it] other than buying a WD External drive :slight_smile:


Appreciate your support.

If you’re using network shares and media library, then the green button should be active 100% of the time…  

Tony, I’m going to give you a break and I will just play with the system for a while. Should have done this before I loaded 1Tb on the NAS, as my last play [removinging then reading the lib] took an age!