How to copy from external USB 3.0 disk to NAS?

I have about 2TB of files stored on an external Seagate Backup Plus drive (USB 3.0) and need to copy them across to my My Cloud EX2. I need to retain the original file attributes (ie. date stamps) and also the original directory structure.

I tried using Windows at first (simple copy/paste via File Explorer in Windows 10) but this was unacceptable as it was going to take about 5 days!

I then tried plugging the Seagate drive directly into the NAS, and tried using the My Cloud dashboard to do a “USB Backup”. This was a lot quicker, presumably as there was no ethernet bottleneck, and also had the advantage of not requiring the PC to be on throughout the transfer, but the problem is, that method places the files into a rigid backup folder structure which is predetermined by the My Cloud backup system - but I need to retain the folder structure that exists on the Seagate drive.

I then tried to remedy that by doing an “Internal Backup” of the original “USB Backup” but that didn’t work, for the same reason.

All I want to do is a simple transfer of existing files/folders from my old external drive to my new WD NAS - am I missing something obvious, because surely there must be an easy and fast way to do this?

PS: According to this calculator http://wintelguy.com/transfertimecalc.pl it should take just under an hour to transfer 2TB over USB 3.0. I realise that in practise it would most likely take longer, but surely with a USB 3.0 drive connected to the EX2’s USB 3.0 port, the most it should take is a couple of hours… if it can be done at all?

Hello,

You have already try the options that I could suggest. As a recommendation, try creating a case with support to see if they have any additional information about it.

Also, let’s see if any of the users can share some information about it.

Real easy, if you have the “right stuff”.

I have done this more than once and I get transfers of 113MB/sec using the right stuff. 2TB should not take 5 days!

I have a gigabit network with gigabit network switches attached. My DL2100 NAS and fast Win 10 laptop are connected to same network switch. If I connect a USB3 portable drive to my PC and use File Explorer to do the transfer I get the aformentiond speeds. 2TB transfer takes a few hours, Just transfer a folder at a time at first, check results, if OK do more than a folder at a time. FIle stamps remain the same, although since new folders are being created on NAS they have current time/date stamps. Your speeds will not be as fast as mine with your EX2, but I would guess they are close to under 100 MB/sec.

Thanks, it seems that you are achieving almost the maximum theoretical throughout for Gigabit. I’m using a Cisco DPQ3925 cable-modem/router, which is rated for Gigabit ethernet. There are no additional network switches in the network. So both my Win10 laptop and my EX2 are connected directly to the Cisco.

I’m only ‘sorta kinda sure’ that the cables I’m using are CAT5 rated though - but maybe some of them aren’t - and if not, could that be the bottleneck?

My DL2100 is rated by WD at 115 MB.sec and I occasionally see it peak to 114. Has a very fast Intel dul core CPU. Anyway, CAT5e or even Cat 6 are best for gigabit. What transfer speeds are you getting?

My Asus RT-N66U router is tweaked to perfection, too. The tweaking concerns mostly the wireless signal, tho. The high transfer speeds are for large files; lots of small files actually slow things down.

The 2TB comprises all sorts of file sizes, since it’s photos, music, videos, general files, the lot. As a test, I just copied 500GB - one very large file and three quite small ones - and it took 17.5", so that’s about 28MB/s. Windows agreed, showing speeds of between 20 & 40 MB/s throughout the process. This is really way too slow though. When I get a chance I’ll check out my spare cables and see if I can find some that are specifically rated CAT5e if I can, then re-try the test.

Yes, it beieve it is too slow, too.
If you are in US, I have been getting my CAT5e cables at Home Depot, they are quality cables yet not at a “Best Buy” price point. I get the shortest cables I need for the job; ususlly 3ft, 7 ft and I have a few one footers.

Thanks Mike, I’m not in the US, but anyway I checked my cables. The 4-foot cable between the laptop and the router was CAT5e. But the 7-foot cable between the EX2 and the router was only CAT5. I found a spare 7-foot CAT5e and replaced it with that, then re-ran the same test: achieved an improved average of 47MB/s.

I then rebooted the laptop, NAS and the router, and prevented a couple of potentially internet-hungry apps from running, jic that made any difference (online backup and VPN).

Re-ran the same test (ie with the same files) and the initial result was actually worse, only 27MB/s. But then I re-ran it a few more times and got various results, on average pretty much the same as before the reboot, about 45MB/s.

I then tried a completely different bunch of files (much smaller files, and 1.5GB altogether rather than 1GB, so maybe more of a ‘real world’ test?) and that took 41.3" - only 36MB/s average.

This is not real encouraging. I do have a different router I could try connecting everything up to, it’s a D-Link DSL-2890AL (a gigabit-rated ADSL modem/router) so I guess this is the next logical thing to try? It will need to wait till tomorrow though…

Routers come in various levels of quality. I got my Asus because it was highly rated and PC Mag chose it Editor’s Choice.

OK, well my Cisco cable router was provided by my cable ISP. My D-Link router is much newer, and I use it for my DSL connection. So… tried the same tests with the D-Link, but got very similar speed results.

But this is interesting - the D-Link router, being newer I suppose, has LEDs that change colour depending on whether it detects you’re on a Gigabit network (green LED) or on a 10/100 network (yellow LED) and guess what - both LEDs (for the laptop and the EX2) were yellow!

This is really confusing because my laptop has a Gigabit ethernet controller, so does the EX2, and I’ve connected them both to the router with short CAT5e cables. So I’m confused as to why I’m getting two yellow LEDs rather than two green ones…

Also, “Fast Ethernet” (as distinct from “Gigabit Ethernet”) is only rated at 100Mbps, which I take to be 12.5MB/sec? And I’m getting at least double that speed, even on a slow run, so I really have no idea why the yellow LEDS!

I believe y ou can directly connect the computer ethernet to the NAS ethernet input and take the home network completely out of the picture to test your speed. If much faster, then use it that way to transfer the HD contents.

I do know that both devices can be connected directly through the same gigabit switch (and no internet connection) to do above.

That was a great idea, thanks. It worked, but unfortunately didn’t realize any speed improvement. I then tried swapping cables (remember both of them are short lengths and rated CAT5e) and the second cable was considerably slower.

Initially this made me think “ah, so the quality of the cable can make a big difference…” so then I swapped back again to the original cable and re-ran the tests, assuming it would speed up again - but the speed stayed low!

Needless to say, this is doing my head in! Anyway, we have effectively eliminated the routers from the picture. My best guess is that the inefficiency and speed inconsistency can perhaps be blamed on Windows? If so, this is why I would love to be able to take the O/S right out of the picture.

For my next test I’m going to go back to what I did originally - plug the USB3 drive directly into the EX2 - and re-try the My Cloud dashboard’s “USB Backup” feature. I know that this is not a solution to the problem, as it places the files/folders into its own structure, rather than keeping the original structure - but I will at least be able to measure the actual transfer speed, which is something I didn’t do originally.

What are WD’s published specs for file transfers?

I doubt that Windows is to blame. My results are from a Windows 10 HP top-end laptop.

Good question - I can’t find any published specs anywhere.
Appendix G of the 169-page user manual states only:
Ethernet: High performance (100/1000) Gigabit Ethernet connection
Data transfer rate: USB 3.0 up to 5 Gb/s
*A USB 3.0 host and USB 3.0 certified cable are required to obtain USB 3.0 performance.

There is a very comprehensive performance review here http://www.storagereview.com/wd_my_cloud_ex2_review but it’s beyond my understanding.

I don’t want to read a review, I want YOU to know the transfer rate you are aiming for so you know if there is a problem or not. There is probably a good reason for not publishing the rate; it is likely low. It could turn out that you ARE getting the max rate, but without knowing the spec you are in the dark. Contact WD for this info if necessary.

OK, I looked at the review, it does not give performance specs that are useful regarding read-write speeds. but review does say “As far as performance goes, it was expectedly a bit underwhelming when compared to others in its class . . .”

Review refers us to the EX4 review as to having similar specs, and it concludes with this comment, "The EX4 does draw a degree of criticism over its performance speed, which could be a bit better compared to other similarly-designed competitor models ".

Bottom line is: you do not have a speed demon NAS. To get this,one needs the upper end products from WD (e.g. such as my DL2100)

Like I say, get the actual read/write speeds so you know your limits.

I just tried a comprehensive “Internal Backup” job comprising 83.9GB of files of various sizes. It took 40 minutes (to the nearest minute) which is an average transfer speed of just 35.8MB/s - so it certainly ain’t no speed demon.

This was done via the My Cloud Dashboard, which is a web interface, so effectively it takes the PC, the USB controller and router right out of the picture, because you’re only transferring files from the NAS array to a different location on the same NAS array. I might be wrong, but this is probably the absolute purest/fastest form of file transfer that the NAS can manage, would you agree?

My math isn’t great but I calculate that at that speed it should take just over 16 hours to transfer 2TB of data. Which is acceptable I suppose. Except for the fact that I need to transfer it via USB3, not internally… and I still need to run that speed test…

OK, I have now run a couple of tests to verify the speed of USB3 to NAS transfers, with the USB drive plugged directly into the NAS - again, done via the My Cloud dashboard, so the PC and the router can’t be responsible for any slowdowns.

First I created a USB Backup job to transfer 0.97GB of music, which took 7’26" to run - an average speed of just 2.2MB/second!

I thought that can’t be right, so I tried it a second time, this time transferring 894MB of photos. It took 6’36", which is 2.3MB/sec, pretty much the same. At that speed it would take about 10 days to transfer 2TB worth of files! I think either my math is terrible or something is really wrong here…

I think for the last part of the test, I need to plug the USB drive back into my laptop and measure the transfer speed without the NAS in the picture. Because it’s either the NAS or the external drive that’s got to be responsible for this sluggishness, right?

I really do not know what to further say, but you have the slowest bottom of line NAS. I just responded to a guy complaining about how slow his EX4 is. Same situation. If one wants a fast NAS they gotta pay for a top of the line unit (like my DL2100 was at the time) or just accept the slowness of their EX2 and EX4.

Thanks for all your help Mike. I might raise a support case as ERmorel suggested, as I’m not sure what the specs are supposed to be, but it seems to me that even being an economical NAS, it should probably be performing better than this.