How to copy data from old WD-2540 EIDE drive to USB

I am trying to help someone with an old PC, he runs his small business on a DOS version of FoxPro on a Western Digital Caviar WD-2540 EIDE HDD. The machine is an old Gateway 2000 with a 486 CPU. I fear that the old hard drive or the PC itself will fail at any minute, causing this poor guy to go out of business.

I have built a new machine running DOS 7.1 with new hardware. That new machine can read data from USB flash drives with no problem.

I would like to copy about 220 MB of data from the old Western Digital Caviar WD-2540 EIDE HDD to a USB flash drive. I have tried to hang that Western Digital Caviar WD-2540 EIDE HDD off of a Windows 10 machine using an IDE-to-USB dongle - the drive is “seen” by Windows but Windows says “no media in drive” and I can’t mount it in Windows.

I tried connecting the Western Digital Caviar WD-2540 EIDE HDD to the new PC using an IDE interface card that I bought; upon booting, the card’s BIOS “sees” the Western Digital Caviar WD-2540 EIDE HDD but I can’t mount the drive to the PC to copy the data, neither can I boot from that drive. (the BIOS is in “legacy” mode, not UEFI)

How can I read this drive on a PC that has USB so I can copy the data over? Even with an IDE card in a new-ish PC I cannot mount this drive.

FYI the drive works fine in the old Gateway 2000 486 PC. The Western Digital Caviar WD-2540 EIDE HDD seems to have no problems currently- but I need to get that data off that drive because sooner or later it WILL fail - it is 27 years old!

FYI #2 I couldn’t mount the drive in anything with jumper set to MASTER or to SLAVE.


I assume that you mean try mounting the drive using the USB-to-IDE dongle.I’ll try Ubuntu, my notebook is dual-boot.

The old DOS machine has Lantastic on it, so copying over the network could be possible - if I can connect another machine to it somehow. Maybe my new DOS 7.1 machine? It has an Ethernet port, but I wonder how hard it will be to get that new DOS machine to run Lantastic… not sure if I will need some kind of driver for the PCIE ethernet adapter that is built in to the machine, I wonder can Lantastic “see” an Intel Ethernet adapter that is on the PCIE bus… or is it possible to connect my Windows 10 PC via it’s ethernet adapter- some kind of Lantastic stack I can load? Ubuntu might work too, but I think I would really struggle to get Ubuntu configured for Lantastic over a PCIE ethernet adapter…

You would need an AC Powered USB Dock or Enclosure

USB Dongles (5V Powered Bus) only power 2.5" Drives … for 3.5" Drives you need 12V External Power.

My dongle also comes with an AC-to-DC power supply that has a cable that plugs into the drive’s 4-pin Molex connector to provide power to the drive.

The dongle that I use does not attempt to power the drive off the USB power.

sounds more like an USB Adapter than a USB Dongle … Dongles typically doesn’t have 12V External Power and are powered by the 5V USB Bus.

Tried reading the Western Digital Caviar WD-2540 EIDE HDD with the USB dongle / drive PSU using a machine running Ubuntu. Same results as with Windows. Ubuntu saw the drive but reported “No Media” so, yeah, Ubuntu didn’t work either.

Any other suggestions? The old Gateway 2000 machine works with this drive perfectly well. However, short of using ~170 floppy disks, I can find no way to transfer the data off of this drive.