How to configure MyCloud (3TB) for access with drive letter on Windows 7?

I have a newly installed WD MyCloud 3TB. It’s been sitting in the box for a good while (perhaps a year) so there’s probably a newer model available, but it’s new to me.

After attaching the supplied Ethernet cable from my router to the MyCloud, and powering up the MyCloud, the LED on the front panel was initially flashing and after a short time it stopped flashing and became solidly lit (Blue) and has remained solidly lit ever since.

I successfully completed the initial installation/setup (mycloud.com/setup) on my Windows 7 (Home Premium 64bit) computer and completed the recommended MyCloud firmware update with no problems. I haven’t downloaded/installed any “optional” modules/apps although some may have been automatically installed during setup.

For my initial use of the MyCloud, I’m trying to configure it to allow access by drive letter so I can backup an existing internal hard drive by (manually) copying files/folders using perhaps Robocopy or something similar, while I replace the internal drive.

What do I need to check/configure or download/install to allow accessing the MyCloud with a drive letter, for example from a windows cmd.exe command prompt or Windows Explorer? Initially I could configure the whole (about) 3TB as 1 drive letter, but I’ll only need less than 1TB (perhaps 750BG) for the backup so if it’s not a significant issue, I’d like to partition the remainder for other uses.

I watched the WD video series but it didn’t (unless I missed one) talk about drive letters.

I also looked online (mostly YouTube) but I couldn’t find what I need. The only YT video I found about assigning a drive letter didn’t match the interface I currently see… it may have had modules/apps installed that I don’t have, or it may have been for a different/similar product like MyCloud Home.

Is there a tutorial video series available that would help me, or could someone help me get started with this?

Also, (perhaps a deserving of a topic/question of its own): Currently the only access I know is using browser with MyCloud local IP (192.168.x.y). Is there another interface I could/should be using?

Try mapping a Share.

Note: Mapping a Share is explained in the My Cloud User Manual. If you haven’t done so already you should read through the User Manual to learn how to use the various features and options of the My Cloud device.

https://support.wdc.com/product.aspx?ID=904

Generally one uses Window File Explorer to access the My Cloud on the local network. This too is explained in the My Cloud User Manual.

Thanks for the quick reply.

I performed the procedure described at the link you provided and it seems to have gotten me most of way there.

The “WD MyCloud” is shown as a network server/device named: \WDMyCloud

Previously (during initial setup/install) I created a “Share” on the “WD MyCloud”, named “QnewP”.

Following the instructions on the linked page, I opened the Windows “Map Network Drive” dialog and:
1 Selected an unused drive letter N:
2 Clicked the “Browse” button
3 In the “Browse For Folder” dialog that opened, I selected:
\WDMYCLOUD\QNEWP
4 I clicked OK, then Finish.

At this point, from a Windows Explorer window, I can access the WD MyCloud by opening N:, and for example creating a new folder. This part seems to be working fine.

Next though, I opened a cmd.exe command prompt (as Administrator).

If I try setting drive N: as my current drive, I get an error:
“The system cannot find the drive specified.”

If I type: net share
I see a list of shares, but N: is not shown.

If I type: net use N: \WDMYCLOUD\QnewP
I get a message that “The command completed successfully.”, and N: is accessible.

It seems this drive map is now remembered for new command windows, until the next time I reboot the computer, so it’s not a big deal, but is it possible to set this to be remembered for after the next reboot, so I don’t have to go in and manually do this each time?.

To have a mapped share stick through a reboot or turning the PC off and on. Make sure to check the option “Reconnect at logon” when mapping the Share.