How to boot linux from My passport


#1

I just bought a USB 3.0 500 GB My Passport. I want to install linux on it and boot any PC with it. I was able to install linux but no BIOS is able to boot from it. I tried 3 PCs. One BIOS found “WD SES device” and when I select that as the boot device, it can’t boot. it skips that device and goes to the next one in the list.

On a Redhat linux systme, I tred to mount this external drive and it says it can’t detect a file system. There are two parittions (one /boot and one /); it shows two partitions but can’t even mount them.

Does this drive work with linux at all? Is it due to the smartware or whatever? Do I need to load linux with those drivers before I can read frm it?

is it possible to boot directly from this device from BIOS?

I’m on the verge of returning this. So PLEASE help

thanks

sri


#2

I have a My Passport Essential 500 Gb drive and I installed Linux on it and it works great. I’ve been able to backup a couple computers to it without issue. What type of Linux install did you do? Do the computers you tried to boot support booting from a USB drive?


#3

Hey bkrone.  Do you have grub installed on the ‘my passport’ or are you using grub on the host machine?  My old WD 160GB external will boot just fine on numerous machines but for some reason my ‘500GB My Passport’ will not do the same.