How long should factory restore take?

I received my new 3Tb WDMyCloud yesterday. Everything was good until I upgraded the firmware, and I copied a handful of files to it.

After I upgraded the firmware I discovered that I could not access the drive through windows explorer using the device name (accessing via IP address was fine)

I tried the system restore from the dashboard, it didn’t work and then a full restore from the dashboard. Once I realised this would take a long time I switched to quick restore. After approx 15-20 this had appeared to hang so I unplugged it.

Unfortunately I can no longer access the MyCloud drive.

I have tried resetting the box (didn’t work), and just attempted to restore the box to factory settings. I now see a blue solid LED in the front, a solid amber led in the back and a green flashing led in the back.

Would appreciate if someone could help me with the following questions:

How long should a default factory reset take?
What is the best way to get the box back to its original state?



I am back online, so it must have worked.  I found the drive under a different IP address.  Not sure why device name is not recognisable …

A System Only restore takes about 5 to 10 minutes.

A Quick Restore takes substantially longer as it has to reformat the disk.

A Full Restore takes a LONG time (and depends on the size of the disk) because it destroys the data on the drive by writing all zeros over the disk.   It can take more than a day, perhaps for 4TB.

25h for a 4TB unit

1 Like